poj3621 SPFA判断正环+二分答案

Farmer John has decided to reward his cows for their hard work by taking them on a tour of the big city! The cows must decide how best to spend their free time.

Fortunately, they have a detailed city map showing the L (2 ≤ L ≤ 1000) major landmarks (conveniently numbered 1.. L) and the P (2 ≤ P ≤ 5000) unidirectional cow paths that join them. Farmer John will drive the cows to a starting landmark of their choice, from which they will walk along the cow paths to a series of other landmarks, ending back at their starting landmark where Farmer John will pick them up and take them back to the farm. Because space in the city is at a premium, the cow paths are very narrow and so travel along each cow path is only allowed in one fixed direction.

While the cows may spend as much time as they like in the city, they do tend to get bored easily. Visiting each new landmark is fun, but walking between them takes time. The cows know the exact fun values Fi (1 ≤ Fi ≤ 1000) for each landmark i.

The cows also know about the cowpaths. Cowpath i connects landmark L1i to L2i (in the direction L1i -> L2i ) and requires time Ti (1 ≤ Ti ≤ 1000) to traverse.

In order to have the best possible day off, the cows want to maximize the average fun value per unit time of their trip. Of course, the landmarks are only fun the first time they are visited; the cows may pass through the landmark more than once, but they do not perceive its fun value again. Furthermore, Farmer John is making the cows visit at least two landmarks, so that they get some exercise during their day off.

Help the cows find the maximum fun value per unit time that they can achieve.

Input

* Line 1: Two space-separated integers: L and P
* Lines 2..L+1: Line i+1 contains a single one integer: Fi
* Lines L+2..L+P+1: Line L+i+1 describes cow path i with three space-separated integers: L1i , L2i , and Ti

Output

* Line 1: A single number given to two decimal places (do not perform explicit rounding), the maximum possible average fun per unit time, or 0 if the cows cannot plan any trip at all in accordance with the above rules.

Sample Input

5 7
30
10
10
5
10
1 2 3
2 3 2
3 4 5
3 5 2
4 5 5
5 1 3
5 2 2

Sample Output

6.00


http://blog.csdn.net/sdj222555/article/details/7692185 //代码就不客气的搬一下了 太懒了 。

SPFA判正环
1.初始每个顶点的值为0,并开一个计数数组记录每个顶点被增大的次数;
2.常规手段压入压出压入压出
3.倘若被增大的次数大于顶点数,那么一定存在正环,关于问什么要大于顶点数,那是因为会出现极端情况,就是每个点都有一条正向边连向同一个点(貌似等于n就可以了)。
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <queue>
#define MAXN 1005
#define MAXM 50005
#define INF 1000000000
#define eps 1e-6
using namespace std;
struct node
{
    int v, next;
    double w;
}edge[MAXM];
int head[MAXN], e, vis[MAXN], q[50 * MAXM], c[MAXN];
int n, m;
double d[MAXN], val[MAXN];
void insert(int x, int y, double w)
{
    edge[e].v = y;
    edge[e].w = w;
    edge[e].next = head[x];
    head[x] = e++;
}
bool spfa(double mid)
{
    int h = 0, t = 0;
    for(int i = 1; i <= n; i++)
    {
        vis[i] = c[i] = 1;
        q[t++] = i;
        d[i] = 0;
    }
    while(h < t)
    {
        int u = q[h++];
        vis[u] = 0;
        for(int i = head[u]; i != -1; i = edge[i].next)
        {
            int v = edge[i].v;
            double w = val[u] - mid * edge[i].w;
            if(d[v] < d[u] + w)
            {
                d[v] = d[u] + w;
                if(!vis[v])
                {
                    q[t++] = v;
                    vis[v] = 1;
                    c[v]++;
                    if(c[v] > n) return 1;
                }
            }
        }
    }
    return 0;
}
int main()
{
    int x, y;
    double w;
    e = 0;
    memset(head, -1, sizeof(head));
    scanf("%d%d", &n, &m);
    for(int i = 1; i <= n; i++) scanf("%lf", &val[i]);
    for(int i = 1; i <= m; i++)
    {
        scanf("%d%d%lf", &x, &y, &w);
        insert(x, y, w);
    }
    double low = 0, high = 1000;
    while(high - low > eps)
    {
        double mid = (low + high) / 2;
        if(spfa(mid)) low = mid;
        else high = mid;
    }
    printf("%.2f\n", low);
    return 0;
}

 

posted @ 2017-07-26 17:33  Billyshuai  阅读(175)  评论(0编辑  收藏  举报