zoj 3210 A Stack or A Queue? (数据结构水题)


A Stack or A Queue?

Time Limit: 1 Second      Memory Limit: 32768 KB

Do you know stack and queue? They're both important data structures. A stack is a "first in last out" (FILO) data structure and a queue is a "first in first out" (FIFO) one.

Here comes the problem: given the order of some integers (it is assumed that the stack and queue are both for integers) going into the structure and coming out of it, please guess what kind of data structure it could be - stack or queue?

Notice that here we assume that none of the integers are popped out before all the integers are pushed into the structure.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

Each test case contains 3 lines: The first line of each test case contains only one integer N indicating the number of integers (1 <= N <= 100). The second line of each test case contains N integers separated by a space, which are given in the order of going into the structure (that is, the first one is the earliest going in). The third line of each test case also contains N integers separated by a space, whick are given in the order of coming out of the structure (the first one is the earliest coming out).

Output

For each test case, output your guess in a single line. If the structure can only be a stack, output "stack"; or if the structure can only be a queue, output "queue"; otherwise if the structure can be either a stack or a queue, output "both", or else otherwise output "neither".

Sample Input

4
3
1 2 3
3 2 1
3
1 2 3
1 2 3
3
1 2 1
1 2 1
3
1 2 3
2 3 1

Sample Output

stack
queue
both
neither


水题一道~,主要是考察栈和队列的基本原理,先入先出的是队列,后入先出的是栈~,

主要是对输入和输出进行推断即可了,是否能与他们吻合。

以下是ac的代码:

#include <iostream>
#include <cstdio>
using namespace std;
const int maxn=120;
int a[maxn];
int main()
{
   int t,n,x;
   scanf("%d",&t);
   while(t--)
   {
       bool isqueue=true; //推断是栈还是队列
       bool isstack=true;
       scanf("%d",&n);
       for(int i=0;i<n;i++)
        scanf("%d",&a[i]);
       for(int i=0;i<n;i++)
       {
        scanf("%d",&x);
        if(x!=a[i])
            isqueue=false;
        if(x!=a[n-i-1])
            isstack=false;
       }
       if(isstack&&isqueue)
          printf("both\n");
       else if(isqueue)
        printf("queue\n");
       else if(isstack)
        printf("stack\n");
       else
        printf("neither\n");
   }
    return 0;
}

posted @ 2015-01-06 18:05  mfrbuaa  阅读(250)  评论(0编辑  收藏  举报