hdoj 3351 Seinfeld 【栈的简单应用】


Seinfeld

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1373    Accepted Submission(s): 678


Problem Description
I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.
 

Input
Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)

 

Output
For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.
 

Sample Input
}{ {}{}{} {{{} ---
 

Sample Output
1. 2 2. 0 3. 1

用栈将全部满足配对的都删去。最后剩下的就是}}}{{{或{{{{{或}}}}}统计一下左括号和右括号的数目,处理一下就好了

代码:

#include <stdio.h>
#include <string.h>
#include <stack>
#include <algorithm>
using namespace std;

char c[1005], temp[1005];
stack<char> s;
int main(){
    int v = 1;
    while(gets(c), c[0] != '-'){
        int i, len = strlen(c);
        s.push(c[0]);
        for(i = 1; i < len; i ++){
            if(!s.empty()){
                if(s.top() == '{'&&c[i] == '}'){
                    s.pop(); continue;
                }
                else s.push(c[i]);
            }
            else s.push(c[i]);
        }
        int sum1 = 0, sum2 = 0;
        while(!s.empty()){
            if(s.top() == '}') ++sum1;
            else ++sum2;
            s.pop();
        }
        int ans = (sum1+1)/2+(sum2+1)/2;
        printf("%d. %d\n", v++, ans);
    }
    return 0;
}


posted @ 2017-07-16 19:48  mfmdaoyou  阅读(223)  评论(0编辑  收藏  举报