hdoj Let the Balloon Rise



/*Let the Balloon Rise

Problem Description

Contest time again! How excited it is to see balloons floating around.
But to tell you a secret, the judges' favorite time is guessing the most popular problem.
When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
Input

Input contains multiple test cases. Each test case starts with a number
N (0 < N <= 1000) -- the total number of balloons distributed.
The next N lines contain one color each. The color of a balloon is a string of up to
15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line.
It is guaranteed that there is a unique solution for each test case.
Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0


Sample Output

red
pink*/

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
# define N 1005
char str[N][15];
int main()
{
	int i,j,count[1000],t,n,k;
	while(scanf("%d",&n),n!=0)
	{
		t=0;记着要清零。 
		for(i=0;i<n;i++)
		scanf("%s",str[i]);
		memset(count,0,sizeof(int)*1000);//把count都初始为0 
		for(i=0;i<n;i++)
		{
			for(j=i+1;j<=n;j++)
			{
			if(strcmp(str[i],str[j])==0)
			{
				count[t]++;
			}
		    }
			t++;
		}
		k=0;
		for(i=0;i<t;i++)
		{
			if(count[i]>=count[k])
			k=i;
		}
		printf("%s\n",str[k]);
	}
	return 0;
}

posted @ 2017-05-26 20:06  mfmdaoyou  阅读(188)  评论(0编辑  收藏  举报