HDU--2053

Switch Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12748    Accepted Submission(s): 7753


Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 

Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
 

Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 

Sample Input
1 5
 

Sample Output
1 0
Hint
hint
Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.
 

Author
LL

#include <iostream>
using namespace std;

int main()
{
	int n;
	while (cin >> n)
	{
		int num=0; 
		for (int i=1; i<=n; i++)
		{
			if (n %i ==0)
				num++;
		}
		if (num%2 == 0)
			cout << 0;
		else
			cout << 1;
		cout <<endl;
	}
	return 0;
}

标题实际上是一些必要知识的数量因素,刚开始我的第一个想法是希望保留各自为阵的结果,但很明显的超时。而且很复杂,再详细看题目,见无限,经过一些数字前面发现了几个经营业绩将不会改变,后来我想,这是一个细致的需求因素!!
posted @ 2015-12-08 19:45  mengfanrong  阅读(187)  评论(0编辑  收藏  举报