ACdream 1195 Sudoku Checker (暴力)

Sudoku Checker

Time Limit: 2000/1000MS (Java/Others)Memory Limit: 128000/64000KB (Java/Others)

Problem Description

Sudoku is a popular single player game. The objective is to fill a 9x9 matrix with digits so that each column, each row, and all 9 non-overlapping 3x3 sub-matrices contain all of the digits from 1 through 9. Each 9x9 matrix is partially completed at the start of game play and typically has a unique solution.

      

Given a completed N2×N2 Sudoku matrix, your task is to determine whether it is a valid solution.

A valid solution must satisfy the following criteria:

  • Each row contains each number from 1 to N2, once each.
  • Each column contains each number from 1 to N2, once each.
  • Divide the N2×N2 matrix into N2 non-overlappingN×N sub-matrices. Each sub-matrix contains each number from 1 to N2, once each.

You don't need to worry about the uniqueness of the problem. Just check if the given matrix is a valid solution.

Input

The first line of the input gives the number of test cases, T(1 ≤ T ≤ 100).

T test cases follow. Each test case starts with an integer N(3 ≤ N ≤ 6).

The next N2 lines describe a completed Sudoku solution, with each line contains exactlyN2 integers.

All input integers are positive and less than 1000.

Output

For each test case, output one line containing "Case #x: y", where x is the case number (starting from 1) andy is "Yes" (quotes for clarity only) if it is a valid solution, or "No" (quotes for clarity only) if it is invalid.

Sample Input

3
3
5 3 4 6 7 8 9 1 2
6 7 2 1 9 5 3 4 8
1 9 8 3 4 2 5 6 7
8 5 9 7 6 1 4 2 3
4 2 6 8 5 3 7 9 1
7 1 3 9 2 4 8 5 6
9 6 1 5 3 7 2 8 4
2 8 7 4 1 9 6 3 5
3 4 5 2 8 6 1 7 9
3
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
3
5 3 4 6 7 8 9 1 2
6 7 2 1 9 5 3 4 8
1 9 8 3 4 2 5 6 7
8 5 9 7 6 1 4 2 3
4 2 6 8 999 3 7 9 1
7 1 3 9 2 4 8 5 6
9 6 1 5 3 7 2 8 4
2 8 7 4 1 9 6 3 5
3 4 5 2 8 6 1 7 9

Sample Output

Case #1: Yes
Case #2: No
Case #3: No



大致题意:给一个数独。看看符不符合要求。

PS:做个题还长姿势了。曾经仅仅听过数独,可是没玩过,这次A道题,搞懂了其本规则,哈哈。收获不小。

好了。那就介绍一下规则吧,现给出n^2*n^2的数独,推断是否满足:  

                                                                                                                        1.每行要用1~n^2的数填满,而且每一个数仅仅出现一次。就是把1~n^2排列到每一行。

                                                                                                                        2.行的要求跟列一样;

                                                                                                                        3.还要满足均分成的n^2个n*n的矩形的元素也要满足1~n^2个数的排列。




AC代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int a[40][40], b[40][1000], c[40][1000], d[1000];
int T,t,n;


int main(){
	#ifndef ONLINE_JUDGE
	freopen("in.txt","r",stdin);
	#endif
	scanf("%d", &T);
	for(int t=1; t<=T; t++){
		memset(b,0,sizeof(b));
		memset(c,0,sizeof(c));
		scanf("%d", &n);
		for(int i=1; i<=n*n; i++){                      //处理行列
			for(int j=1; j<=n*n; j++){
				scanf("%d", &a[i][j]);
				b[i][a[i][j]]++;
				c[j][a[i][j]]++;
			}
		}
		int flag = 1;
		for(int i=1; i<=n*n; i++){                      //推断行列
			for(int j=1; j<=n*n; j++){
				if(b[i][j]!=1 || c[i][j]!=1){
					flag = 0;
					break;
				}
			}
		}
		if(flag){
			for(int i=1; i<=n; i++){                //推断每一个n*n矩阵
				for(int j=1; j<=n; j++){
					memset(d,0,sizeof(d));
					for(int k=1; k<=n; k++){
						for(int s=1; s<=n; s++){
							d[a[(i-1)*n+k][(j-1)*n+s]]++;
						}
					}
					for(int k=1; k<=n*n; k++){
						if(d[k]!=1){
							flag = 0;
							break;	
						} 
					}
					if(!flag)  break;
				}
				if(!flag)  break;
			}
		}
		if(flag)  printf("Case #%d: Yes\n", t);
		else  printf("Case #%d: No\n", t);
	}
	return 0;
}


posted @ 2015-06-07 13:36  mengfanrong  阅读(269)  评论(0编辑  收藏  举报