将学习变成乐趣,一直在路上
每天1990

导航

统计
 
背景:
yum包的管理是使用python写的,有对应的python版本
 
遇到的问题报错如下:
File "/usr/bin/yum", line 30
    except KeyboardInterrupt, e:
通过看报错可以了解到是使用了python2的语法,所以了解到当前yum使用的Python2,因为我单独安装了python3,且python3设置为默认版本了,所以导致语法问题
 
解决方法:
使用python2.6 yum install xxx来使用yum命令
注意:python2.6是在/usr/bin下,要使用和2版本一致的名字
posted on 2016-05-05 17:14  每天1990  阅读(12398)  评论(0编辑  收藏