LuckyDan

最怕一生碌碌无为,还安慰自己平凡最可贵!

解决导入MAVEN项目报错Dynamic Web Module 3.1 requires Java 1.7 or newer.

解释:web模块需要使用java1.7及以后的版本,目前的版本不符合。因而只需要修改java版本到1.7及以上即可。
解决方法:
1.保证 在eclipse 构建 web中关于java版本有三处需要修改统一。
 右击项目,选择“propertie”===>分别修改一下内容,保持jdk版本一致
  1.1 修改Java Build Path的libraries版本
    1.2 修改Java Compiler 中的JDK Compliance版本
    1.3 修改Project Facet中java的版本
2. 因为使用了 maven构建项目,还需要在pom.xml文件中的build标签中加入jdk的配置信息
<build>
  <finalName>Spring-activiti</finalName>
  <plugins>
    <plugin>
      <groupId>org.apache.maven.plugins</groupId>
      <artifactId>maven-compiler-plugin</artifactId>
      <version>2.3.2</version>
      <configuration>
        <source>1.8</source>
        <target>1.8</target>
      </configuration>
    </plugin>
  </plugins>
</build>
  3.最后再右键使用maven的Update Project 即可。

posted on 2018-05-17 17:34  mywifelidan  阅读(3546)  评论(0编辑  收藏  举报

导航