HDU 1556 差分,前缀和

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 37911    Accepted Submission(s): 18065


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

 

Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

 

Sample Output
1 1 1 3 2 1
 
 
 
考察简单的差分,前缀和
 
AC代码
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
using namespace std;
int a[100005],d[100005];
int main()
{
    int n;
    scanf("%d",&n);
     while(n!=0)
     {
         int l,r;
         memset(a,0,sizeof(a));memset(d,0,sizeof(d));//a[n]记录每个元素被涂色的次数 
         for(int i=1;i<=n;++i){
             scanf("%d%d",&l,&r);
             d[l]++;d[r+1]--;
         }
         for(int i=1;i<=n;++i){
             d[i]+=d[i-1];//差分数组前缀和 
             if(i!=n)printf("%d ",d[i]);//a[n]后不能有空格 
         } 
         printf("%d",d[n]);
         cout<<endl;
         scanf("%d",&n);
     }
    return 0; 
}
 

01:08:39

2020-02-16

 
posted @ 2020-02-16 01:15  林动  阅读(123)  评论(0编辑  收藏  举报