POJ 1456 Supermarket

Supermarket
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 7764   Accepted: 3297

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185
题目大意:每一件商品都有截止日期,每一天只能出售一个商品,求最大能出售多少价值的东西。
解题方法:贪心法。
#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <vector>
#include <string.h>
using namespace std;

typedef struct
{
    int p;
    int d;
}S;

bool cmp(const S& s1, const S& s2)
{
    return s1.p > s2.p;
}

int main()
{
    int visited[10005];
    int n;
    S s[10005];
    int Maxsum = 0;
    S temp;
    while(scanf("%d", &n) != EOF)
    {
        memset(visited, 0, sizeof(visited));
        Maxsum = 0;
        for (int i = 0; i < n; i++)
        {
            int p, d;
            scanf("%d%d", &s[i].p, &s[i].d);
        }
        sort(s, s + n, cmp);
        for (int i = 0; i < n; i++)
        {
            for (int j = s[i].d; j > 0; j--)
            {
                if (!visited[j])
                {
                    visited[j] = 1;
                    Maxsum += s[i].p;
                    break;
                }
            }
        }
        printf("%d\n", Maxsum);
    }
    return 0;
}

 

posted on 2013-07-23 16:13  lzm风雨无阻  阅读(598)  评论(0编辑  收藏  举报

导航