POJ 1083 Moving Tables

Moving Tables
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 23557   Accepted: 7795

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30
题目大意:该楼层共有400个房间,每边200个房间。最近,公司想进行一些调整,其中包括在房间之间移动很多桌子。因为楼道很窄,桌子很大,只有一张桌子能通过楼道,所以有必要指定一个计划来使桌子移动更加高效。将桌子从一个房间移动到另外一个房间可以在10分钟内完成,当桌子从房间i移动到房间j时,从房间i到房间j部分的楼道被占用(闭区间)。在10分钟内,移动多张桌子如果不共享楼道的话,可以同时进行。
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;

typedef struct
{
    int num;
    char type;
}Move;

bool cmp(const Move &m1, const Move &m2)
{
    return m1.num < m2.num;
}

void Swap(int &a, int &b)
{
    int temp = a;
    a = b;
    b = temp;
}

int main()
{
    Move m[405];
    int ans = 0;
    int nCase;
    int n;
    scanf("%d", &nCase);
    while(nCase--)
    {
        ans = 0;
        scanf("%d", &n);
        int nCount = 0;
        for (int i = 0; i < n; i++)
        {
            int x, y;
            scanf("%d%d", &x, &y);
            if (x > y)
            {
                Swap(x, y);
            }
            if (x % 2 == 0)
            {
                --x;
            }
            if (y % 2 == 0)
            {
                ++y;
            }
            m[nCount].num = x;
            m[nCount++].type = 'b';
            m[nCount].num = y;
            m[nCount++].type = 'e';
        }
        sort(m, m + 2 * n, cmp);
        int temp = 0;
        for (int i = 0; i < 2 * n; i++)
        {
            if (m[i].type == 'b')
            {
                temp++;
                if (temp > ans)
                {
                    ans = temp;
                }
            }
            else
            {
                temp--;
            }
        }
        printf("%d\n", ans * 10);
    }
    return 0;
}

 

posted on 2013-07-22 16:58  lzm风雨无阻  阅读(305)  评论(0编辑  收藏  举报

导航