POJ 2388 Who's in the Middle

Who's in the Middle
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 27445   Accepted: 15856

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output

* Line 1: A single integer that is the median milk output.

Sample Input

5
2
4
1
3
5

Sample Output

3
题目大意:求一组数的中位数。
#include <stdio.h>
#include <iostream>
using namespace std;

int Findmid(int arr[], int left, int right, int x)
{
    if (left >= right)
    {
        return arr[left + x];
    }
    int i = left;
    int j = right;
    int mid = arr[left];
    while(i < j)
    {
        while(i < j && arr[j] >= mid)
        {
            j--;
        }
        arr[i] = arr[j];
        while(i < j && arr[i] <= mid)
        {
            i++;
        }
        arr[j] = arr[i];
    }
    arr[j] = mid;
    if (i - left == x)
    {
        return arr[i];
    }
    else
    {
        if (i - left > x)
        {
            return Findmid(arr, left, i - 1, x);
        }
        else
        {
            return Findmid(arr, i + 1, right, x - (i - left + 1));
        }
    }
}

int main()
{
    int arr[10005];
    int n;
    scanf("%d", &n);
    for (int i = 0; i < n; i++)
    {
        scanf("%d", &arr[i]);
    }
    printf("%d\n", Findmid(arr, 0, n - 1, n / 2));
    return 0;
}

 

posted on 2013-07-15 20:56  lzm风雨无阻  阅读(471)  评论(0编辑  收藏  举报

导航