hdu2709

Sumsets

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1151    Accepted Submission(s): 446


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
 

 

Input
A single line with a single integer, N.
 

 

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

 

Sample Input
7
 

 

Sample Output
6
 
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
__int64 f[1000000];
int main()
{
    __int64 n;
    int i;
    f[1]=1;
    f[2]=f[3]=2;
    f[4]=f[5]=4;
    for(i=6; i<=1000000; i++)
        if(i%2==0)
            f[i]=(f[i-2]+f[i/2])%1000000000;
        else
            f[i]=f[i-1];
    while(~scanf("%I64d",&n))
    {
        printf("%I64d\n",f[n]);
    }
}
posted @ 2013-09-10 20:38  我家小破孩儿  阅读(163)  评论(0编辑  收藏  举报