How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17946    Accepted Submission(s): 8822


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
2 4
 

Author
Ignatius.L
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1856 1325 1198 1102 1162 

推断几个人是否是朋友。。

。。。

。。。。。。。。。

。。。。

。。。

仅仅要我们把这几个人看成几棵树好啦。

。我们就数数有几棵树即可。

既然要数有几棵树。那我们怎么区分它们是不是同一棵树呢?就须要推断它们的老祖宗是不是同样。。

并查集啦 并查集

看代码,看代码。。

先想想思想,再自己动手去做。不要照抄、、、

#include <stdio.h>
#include <string.h>
int fa[1005],n;
int find(int x)
{
	if(fa[x]!=x) fa[x]=find(fa[x]);
	return fa[x];
}
void init()
{
	for(int i=1;i<=n;i++)
	fa[i]=i;
}
int main()
{
	int ncase,m;
	scanf("%d",&ncase);
	while(ncase--)
	{
		scanf("%d %d",&n,&m);
		init();
		for(int i=0;i<m;i++)
		{
			int a,b;
			scanf("%d %d",&a,&b);
			int x=find(a);
			int y=find(b);
			if(x!=y)
			fa[x]=y;
		}
		int count=0;
		for(int i=1;i<=n;i++)
		if(fa[i]==i)
		count++;
		printf("%d\n",count);
	}
	return 0;
}


posted on 2017-06-17 08:40  lxjshuju  阅读(108)  评论(0编辑  收藏  举报