摘要: 问题描述 参考“快速入门:在 Linux 上的 Azure 应用服务中创建 Python 应用” 文档,在App Service For Linux环境中部署Python应用,在添加了pandas,应用本地运行成功,但是部署到App Service后,启动报错:Application Error 问 阅读全文
posted @ 2021-05-11 17:11 编码者卢布 阅读(198) 评论(0) 推荐(1)
摘要: 问题描述 当成功创建一个Web App时,通过高级工具(Kudu)可以查看 Web App的根目录(wwwroot)中有一个默认的文件(hostingstart.html)。它就是应用服务的默认页面。如果没有指定default 或者 index等页面或者Web.config中没有配置rewrite规 阅读全文
posted @ 2021-05-10 15:11 编码者卢布 阅读(163) 评论(0) 推荐(0)
摘要: 问题描述 在Azure App Service添加自定义域名时,遇见了Domain ownership 验证无法通过的问题? 问题解决 因为DNS中配置App Service默认域名和自定义域名的CNAME记录后,在App Service中需要验证该域名的所有权,所以需要在DNS中在增加一条TXT记 阅读全文
posted @ 2021-05-10 15:08 编码者卢布 阅读(329) 评论(1) 推荐(0)
摘要: 问题描述 使用Azure CLI指令部署Azure Spring Cloud项目失败,错误消息提示没有安装“azure.storage.blob”模块 问题分析 根据错误提示,是python的模块中没有安装“azure.storage.blob”模块。所以需要先通过python安装此模块后,即可成功 阅读全文
posted @ 2021-05-10 14:15 编码者卢布 阅读(172) 评论(0) 推荐(0)
摘要: 问题描述 NodeJS项目部署在App Service For Linux环境中,部署完成后应用无法访问,在启动日志中发现错误消息:ERROR - Container XXX_0 for site XXX did not start within expected time limit. Elaps 阅读全文
posted @ 2021-04-30 17:58 编码者卢布 阅读(213) 评论(0) 推荐(1)
摘要: 问题描述 使用媒体服务 v3 对视频进行上载、编码和流式传输示例时,遇见了AAD错误。 TIP: Make sure that you have filled out the appsettings.json file before running this sample.AADSTS90002: 阅读全文
posted @ 2021-04-29 17:51 编码者卢布 阅读(263) 评论(0) 推荐(1)
摘要: 问题描述 比较早期创建的Azure Funciton服务,近期发现在门户中已经启用了Application Insights功能,但是正确配置Applicaiton Insights后,却无法获取关联的Azure Function的监控数据? 问题分析 到目前为止,Azure Function已经经 阅读全文
posted @ 2021-04-28 21:40 编码者卢布 阅读(143) 评论(0) 推荐(0)
摘要: 问题描述 备份网站时由于文件太大了,导致应用服务备份失败。如何解决呢? 问题分析 App Service (应用服务)的备份功能有10GB大小的限制,超过了是无法备份成功的并且该限制是无法扩大的。查看微软云的官方网站,备份功能还有以下限制和要求: 备份和还原功能要求应用服务计划处于标准层、高级层或隔 阅读全文
posted @ 2021-04-27 20:01 编码者卢布 阅读(441) 评论(0) 推荐(1)
摘要: 问题描述 当需要在应用中有大量的出站连接时候,就会涉及到SNAT(源地址网络转换)耗尽的问题。而通过Azure App Service/Function的默认监控指标图表中,却没有可以直接查看到SNAT是否耗尽的问题(可以间接参考App Service Plan级中Metrics的 Socket O 阅读全文
posted @ 2021-04-24 17:08 编码者卢布 阅读(618) 评论(0) 推荐(1)
摘要: 在参考Azure官方文档进行VM创建时,发现其中没有包含如何设置NSG的内容,以及如何在创建时就添加数据磁盘的代码(设置磁盘为SSD类型)。本文的内容以“使用 Java 创建和管理 Azure 中的 Windows VM”为基础,在其中添加如何设置NSG(网络安全组 Network Security 阅读全文
posted @ 2021-04-23 21:44 编码者卢布 阅读(531) 评论(0) 推荐(2)
摘要: 问题描述 Redis根据定价层说明,不同级别支持的连接数最多可达4万(同时),但是当短时间又大量连接请求建立的时候,Redis服务的服务压力非常大,到达100%。严重影响了高响应的要求。最严重时,经常出现Redis Client Operation timeout错误。 问题分析 根据设计,Redi 阅读全文
posted @ 2021-04-23 14:06 编码者卢布 阅读(410) 评论(0) 推荐(1)
摘要: 当需要通过代码的方式执行PowerShell脚本时,可以参考以下的示例。 Azure SDK中提供了两个方法来执行PowerShell脚本 (SDK Source Code: https://github.com/Azure/azure-libraries-for-java/blob/master/ 阅读全文
posted @ 2021-04-22 12:00 编码者卢布 阅读(211) 评论(0) 推荐(0)
摘要: Terraform(全称:Hashicorp Terraform )是一种开源工具,用于预配和管理云基础结构。 它将基础结构编入描述云资源拓扑的配置文件中。 这些资源包括虚拟机、存储帐户和网络接口等。 本文介绍在Windows系统中,如何安装Terraform,并且根据Azure的示例模板创建,在中 阅读全文
posted @ 2021-04-21 15:39 编码者卢布 阅读(733) 评论(0) 推荐(1)
摘要: 问题描述 基于安全的角度来考虑,在网站上线之前用户会对自己的网站进行安全扫描,以防网站因为某些漏洞而被非法攻击。 而在扫描过程中,会发现除了 80 和 443 之外的一些其他端口也被开放了。例如:454, 455, 4020, 4022, 4024 等端口也处于开放状态。 如何禁用Web app的端 阅读全文
posted @ 2021-04-20 15:38 编码者卢布 阅读(554) 评论(1) 推荐(1)
摘要: 问题描述 在Azure媒体服务(AMS: Azure Media Service)中,不管是点播,直播都需要下载manifest文件。而文件中有一段【<c t="6161940" d="749970" r="2" n="0" />】内容,这些内容如何解释呢? <?xml version="1.0" 阅读全文
posted @ 2021-04-17 18:29 编码者卢布 阅读(164) 评论(0) 推荐(0)
摘要: 问题描述 在中国区Azure中,App Service是否支持CI/CD工具部署呢? Windows 和Linux两个系统都是同样的方法吗? 问题解答 目前中国区Azure支持Windows 和 Linux。但是Linux目前的支持是基于容器,所以在部署时候需要先把镜像push到镜像市场中(如:AC 阅读全文
posted @ 2021-04-17 09:35 编码者卢布 阅读(170) 评论(0) 推荐(0)
摘要: 问题描述 如题所述,当在中国区使用Microsoft GraphAPI连接B2C Tenant时候,如何来设置中国区的Endpoint呢?在GitHub的示例中,并没有示例介绍如何连接中国区。如 问题解决 由于中国区的Azure是独立的运行环境,所以与Global不一样。在终结点方面表现最为明显,如 阅读全文
posted @ 2021-04-16 12:24 编码者卢布 阅读(345) 评论(0) 推荐(1)
摘要: 问题描述 使用.Net Framework 4.5.2为架构的Service Fabric微服务应用,在升级后发布到Azure Fabric中,服务无法运行。通过Service Fabric Explorer查看到服务出现Warning。全部的错误消息为: SF Explorer中查看状态 SF副本 阅读全文
posted @ 2021-04-12 15:46 编码者卢布 阅读(997) 评论(0) 推荐(2)
摘要: Azure Graph SDK获取用户列表的问题: SDK中GraphServiceClient如何指向中国区的Endpoint:https://microsoftgraph.chinacloudapi.cn/v1.0 阅读全文
posted @ 2021-04-09 21:27 编码者卢布 阅读(832) 评论(1) 推荐(1)
摘要: 问题描述 Java 云端开发,调用 blob 上传会产生内存溢出,Java上调用的方式如下: InputStream inputStream = new BufferedInputStream(new FileInputStream(file)); CloudBlockBlob blob = con 阅读全文
posted @ 2021-04-08 17:20 编码者卢布 阅读(328) 评论(0) 推荐(0)
摘要: A message is added to the Dead Letter Queue (DLQ) Summary A message is added to the Dead Letter Queue (DLQ). Use the ‘Service Bus Explorer’ tool to id 阅读全文
posted @ 2021-04-07 22:40 编码者卢布 阅读(163) 评论(0) 推荐(0)
摘要: There are three main types of files that an Azure Web App can deal with Persisted files This is what you can view as your web site's files. They follo 阅读全文
posted @ 2021-04-07 22:39 编码者卢布 阅读(169) 评论(0) 推荐(0)
摘要: App Service makes it easy to automatically scale your apps to multiple instances when traffic increases. This increases your app’s throughput, but wha 阅读全文
posted @ 2021-04-07 22:38 编码者卢布 阅读(811) 评论(0) 推荐(0)
摘要: If you get java.net.SocketTimeoutException: Read timed out exception Try setting own timeout value when constructing JedisPool using the following con 阅读全文
posted @ 2021-04-07 22:38 编码者卢布 阅读(194) 评论(0) 推荐(0)
摘要: CORS是一个W3C标准,全称是"跨域资源共享"(Cross-origin resource sharing)。 它允许浏览器向跨源服务器,发出XMLHttpRequest请求,从而克服了AJAX只能同源使用的限制。 本文详细介绍CORS的内部机制。 一、简介 CORS需要浏览器和服务器同时支持。目 阅读全文
posted @ 2021-04-07 22:37 编码者卢布 阅读(1380) 评论(0) 推荐(0)
摘要: 问题描述 使用API获取所有Azure AD中的用户列表,API所参考的文档:https://docs.microsoft.com/en-us/graph/api/user-list?view=graph-rest-1.0&tabs=http,如果想过滤出“Block sign in”为no的人,如 阅读全文
posted @ 2021-04-07 22:15 编码者卢布 阅读(259) 评论(1) 推荐(0)
摘要: 问题详情 使用EPH获取Event Hub数据时,多次出现连接shutdown和LeaseLost的error ,截取某一次的error log如: Time:2021-03-10 08:43:48.4650|NE:VSDN|Machine:RD0003FF01A8BE|Lv:INFO|Activi 阅读全文
posted @ 2021-04-07 21:15 编码者卢布 阅读(361) 评论(0) 推荐(0)
摘要: Question: I'm receiving events from an EventHub using EventProcessorHost and an IEventProcessor class (call it: MyEventProcessor). I scale this out to 阅读全文
posted @ 2021-04-07 16:17 编码者卢布 阅读(220) 评论(0) 推荐(0)
摘要: 问题描述 在Azure App Service中部署的应用,需要连接到Redis中,目标Redis已经集成了虚拟网络(VNET)并且在Redis的网络防火墙中已经添加App Service的出站IP地址到白名单中。但是检查应用日志发现Redis一直无法连接,错误消息为: No connection 阅读全文
posted @ 2021-04-07 12:01 编码者卢布 阅读(413) 评论(0) 推荐(0)
摘要: 问题描述 对于PaaS的Azure Cache for Redis,Azure中有哪些监控方式?是否能有api接口调用来获取监控值? 问题答案 1) 在Redis的门户中,使用Metrics查看Redis的Service Load,Memroy, CPU指标:https://docs.azure.c 阅读全文
posted @ 2021-04-06 22:17 编码者卢布 阅读(311) 评论(0) 推荐(1)