Oil Deposits

链接:
题目:
Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either '*', representing the absence of oil, or '@', representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2

#include<iostream>
using namespace std;

const int M=101,N=101;
char f[M][N];
int n,m,ans;

int bfs(int i,int j)
{
    if(i<0||i>=n||j<0||j>=m) //坐标不合法
        return 0;
    if(f[i][j]=='@')         //如果是油田 
    {
        f[i][j]='*';
        for(int q=-1;q<=1;q++)
            for(int w=-1;w<=1;w++)
                bfs(i+q,j+w);
    }
    return 0;
}

int main()
{
    while(cin>>n>>m)
    {
        if(!n&&!m) return 0;
        ans=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                cin>>f[i][j];
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                if(f[i][j]=='@') 
                {
                    bfs(i,j);
                    ans++;
                }
        cout<<ans<<endl;
    }
    return 0;
}
posted @ 2021-11-17 22:18  longwind7  阅读(37)  评论(0编辑  收藏  举报