随笔分类 -  linux

摘要:linux 禁止 ping 一、修改内核参数 1.临时允许PING操作的命令为:echo 0 >/proc/sys/net/ipv4/icmp_echo_ignore_all 2.永久允许PING配置方法。 /etc/sysctl.conf 中增加一行 net.ipv4.icmp_echo_igno 阅读全文
posted @ 2017-04-13 12:06 snow__wolf 阅读(277) 评论(0) 推荐(0)
摘要:用FileZilla连接ftp出现错误,500 OOPS: cannot change directory:/home/ftp 原因是CentOS系统安装了SELinux,因为默认下是没有开启FTP的支持,所以访问时都被阻止了。 阅读全文
posted @ 2016-12-21 10:51 snow__wolf 阅读(2225) 评论(0) 推荐(0)
摘要:#!/bin/bash # #将解析完毕的日志备份到别的目录 # #日志目录 rjPath=`ls /home/bgftp/orj` #当前时间戳 cur=`date +%s` #一小时 chtm=3600000 for rpath in $rjPath do #获取文件的时间戳 ctm=`date +%s -r /home/bgftp/orj/$rpath` ... 阅读全文
posted @ 2016-12-13 15:44 snow__wolf 阅读(252) 评论(0) 推荐(0)
摘要:获得当天的日期 date +%Y-%m-%d 输出: 2011-07-28 将当前日期赋值给DATE变量DATE=$(date +%Y%m%d) 有时候我们需要使用今天之前或者往后的日期,这时可以使用date的 -d参数 获取明天的日期 date -d next-day +%Y%m%d 获取昨天的日 阅读全文
posted @ 2016-12-12 17:54 snow__wolf 阅读(7513) 评论(0) 推荐(1)
摘要:nginx一直报错, 2016/12/02 10:23:19 [error] 1472#0: *31 connect() failed (111: Connection refused)while connecting to upstream, client: 101.18.123.107, ser 阅读全文
posted @ 2016-12-02 13:49 snow__wolf 阅读(582) 评论(0) 推荐(0)
摘要:使用第三方FTP软件filezilla进行登陆,出现如下错误:状态: 正在连接 192.168.1.6:21...状态: 连接建立,等待欢迎消息...响应: 220 (vsFTPd 2.2.2)命令: USER ftp响应: 331 Please specify the password.命令: P 阅读全文
posted @ 2016-11-28 11:05 snow__wolf 阅读(8558) 评论(0) 推荐(0)
摘要:Connecting to node 172.168.63.202:7001: OK [ERR] Node 172.168.63.202:7001 is not empty. Either the nodealready knows other nodes (check with CLUSTER N 阅读全文
posted @ 2016-11-22 13:13 snow__wolf 阅读(1217) 评论(0) 推荐(0)
摘要:redis 搭建集群时,一直join。。。。 ./redis-trib.rb create --replicas 1 127.0.0.1:6379 127.0.0.1:6380 127.0.0.1:6381 127.0.0.1:6382 127.0.0.1:6383 127.0.0.1:6384 原 阅读全文
posted @ 2016-11-21 18:33 snow__wolf 阅读(2558) 评论(0) 推荐(0)
摘要:这个异常上网查了很久才知道原因: MOVED indicates that you're using Redis Cluster. ShardedJedis is not for Redis Cluster, so you should use JedisCluster instead. Pleas 阅读全文
posted @ 2016-11-21 18:22 snow__wolf 阅读(3788) 评论(0) 推荐(0)
摘要:linux 安装nginx,FastDFS后,启动访问指定文件出错, 文件名称格式化错误. 解决办法: vi /etc/fdfs/mod_fastdfs.conf 将 url_have_group_name=false 改为 url_have_group_name=true 阅读全文
posted @ 2016-11-20 08:07 snow__wolf 阅读(3877) 评论(0) 推荐(0)
摘要:nginx编译错误: 执行如下命令安装缺少的文件即可 阅读全文
posted @ 2016-11-19 22:19 snow__wolf 阅读(292) 评论(0) 推荐(0)
摘要:本文大部分内容翻译自我开始学习AWK时看到的一篇英文文章 AWK Tutorial ,觉得对AWK入门非常有帮助,所以对其进行了粗略的翻译,并对其中部分内容进行了删减或者补充,希望能为对AWK感兴趣的小伙伴提供一份快速入门的教程,帮助小伙伴们快速掌握AWK的基本使用方式,当然,我也是刚开始学习AWK 阅读全文
posted @ 2016-11-03 09:16 snow__wolf 阅读(537) 评论(0) 推荐(0)
摘要:1、输入"uname -a ",可显示电脑以及操作系统的相关信息。 2、输入"cat /proc/version",说明正在运行的内核版本。 3、输入"cat /etc/issue", 显示的是发行版本信息 4、lsb_release -a (适用于所有的linux,包括Redhat、SuSE、De 阅读全文
posted @ 2016-10-28 16:03 snow__wolf 阅读(337) 评论(0) 推荐(0)
摘要:最简单的例子 —— Hello World! 关于输入、输出和错误输出 BASH 中对变量的规定(与 C 语言的异同) BASH 中的基本流程控制语法 函数的使用 最简单的例子 —— Hello World! 关于输入、输出和错误输出 BASH 中对变量的规定(与 C 语言的异同) BASH 中的基 阅读全文
posted @ 2016-10-11 19:07 snow__wolf 阅读(82451) 评论(2) 推荐(4)
摘要:在svn版本库的hooks文件夹下面,复制模版pre-commit.tmpl cp pre-commit.tmpl pre-commit chmod +x pre-commit vi编辑,如下: #!/bin/sh #必须填写注释且不少于5个字 REPOS="$1" TXN="$2" # Make sure that the log message contains some text.... 阅读全文
posted @ 2016-06-30 10:56 snow__wolf 阅读(385) 评论(0) 推荐(0)
摘要:Redis集群 (要让集群正常工作至少需要3个主节点,在这里我们要创建6个redis节点,其中三个为主节点,三个为从节点,对应的redis节点的ip和端口对应关系如下) 127.0.0.1:6379127.0.0.1:6380 127.0.0.1:6381 127.0.0.1:6382 127.0. 阅读全文
posted @ 2016-05-06 00:04 snow__wolf 阅读(371) 评论(0) 推荐(0)
摘要:zlib官方网站:http://www.zlib.net上下载源码来安装zlib软件包。目前最新版本zlib是zlib1.2.8,安装开始;$wget http://www.zlib.net/zlib-1.2.8.tar.gz$tar -xvzf zlib-1.2.8.tar.gz$cd zlib- 阅读全文
posted @ 2016-05-05 13:40 snow__wolf 阅读(6050) 评论(0) 推荐(0)
摘要:在linux系统中复制文件夹时提示如下: Shell: cp: omitting directory `foldera/' Shell: Shell: 其中foldera是我要复制的文件夹名,出现该警告的原因是因为foldera目录下还存在目录,所以不能直接拷贝。 解决办法:使用递归拷贝,在cp命令 阅读全文
posted @ 2016-05-05 06:13 snow__wolf 阅读(383) 评论(0) 推荐(0)
摘要:1.下载mysql wget http://dev.mysql.com/get/Downloads/MySQL-5.7/mysql-5.7.12-1.el6.x86_64.rpm-bundle.tar 2. 解压 tar -xf mysql-5.7.12-1.el6.x86_64.rpm-bundl 阅读全文
posted @ 2016-04-25 12:53 snow__wolf 阅读(10080) 评论(0) 推荐(0)
摘要:1. 下载svn(subversion) yum install subversion 2.查看svn位置(其实看不看都无所谓) 3.创建svn版本库目录 svnadmin create /home/svnrepos 创建完成后会生成几个文件 4.进入conf目录(该svn版本库配置文件) auth 阅读全文
posted @ 2016-04-24 07:18 snow__wolf 阅读(220) 评论(0) 推荐(0)