SQL   Server   的每个数据库最多可存储   20   亿个表,每个表可以有   1024   列。表的行数及总大小仅受可用存储空间的限制。每行最多可以存储   8,060   字节。如果创建具有   varchar、nvarchar   或   varbinary   列的表,并且列的字节总数超过   8,060   字节,虽然仍可以创建此表,但会出现警告信息。如果试图插入超过   8,060   字节的行或对行进行更新以至字节总数超过   8,060,将出现错误信息并且语句执行失败。  
   
  包含   sql_variant   列的   CREATE   TABLE   语句可以生成下列警告:  
   
  The   total   row   size   (xx)   for   table   'yy'   exceeds   the   maximum   number   of   bytes   per   row   (8060).   Rows   that   exceed   the   maximum   number   of   bytes   will   not   be   added.  
  出现该警告是因为   sql_variant   的最大长度只能为   8016   字节。当某个   sql_variant   列包含与最大长度接近的值时,它可以超过行的最大大小限制。