centos7编译安装php 遇到的问题

centos7 编辑安装php遇到的问题:

./configure 配置遇到的No package 'libxml-2.0' found缺失libxml2.0 库,解决方法:

yum -y install libxml2
yum -y install libxml2-devel

./configure 配置遇到的No package 'sqlite3' found,解决方法:

yum install sqlite-devel

 configure: error: Please reinstall the BZip2 distribution 解决方法:

yum install bzip2 bzip2-devel

configure: error: Package requirements (oniguruma) were not met:

No package 'oniguruma' found

yum install https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/o/oniguruma-5.9.5-3.el7.x86_64.rpm
yum install https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/o/oniguruma-devel-5.9.5-3.el7.x86_64.rpm

 

configure: error: Package requirements (libxslt >= 1.1.0) were not met:

No package 'libxslt' found

yum install libxslt-devel

 

configure: error: Package requirements (libpng) were not met:

No package 'libpng' found

yum install libpng-devel

 

posted @ 2019-12-10 15:05  远洪  阅读(3143)  评论(0编辑  收藏