hdu 5001(概率DP)

Walk

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1083    Accepted Submission(s): 694
Special Judge


Problem Description
I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling.

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.
 

 

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node a and node b.

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.
 

 

Output
For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.

Your answer will be accepted if its absolute error doesn't exceed 1e-5.
 

 

Sample Input
2 5 10 100 1 2 2 3 3 4 4 5 1 5 2 4 3 5 2 5 1 4 1 3 10 10 10 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 10 4 9
 

 

Sample Output
0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.6993317967 0.5864284952 0.4440860821 0.2275896991 0.4294074591 0.4851048742 0.4896018842 0.4525044250 0.3406567483 0.6421630037
 

 

Source
 
题意:图里面有 n 个点,m条边,然后有一个步数 d,问不经过某个点的概率是多少?到达每个点的概率相同,然后从某个点出发到达所有边上的点的概率相同.输出不到所有点的概率.
题解:dp[i][j]代表 j 步到达第 i 个点不经过某个点的概率,将所有能够不经过这个点到达其他点的概率加起来,也就是某个点的答案了,4层循环进行转移.
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <string.h>
#include <vector>
using namespace std;
const int INF = 999999999;
int n,m,d;
vector <int> edge[55];
double dp[55][10005]; ///dp[i][j] 代表不经过某点第 j 步到达第 i 点的概率,枚举每个点

double solve(int x){
    for(int i=1;i<=n;i++) dp[i][0] = 1.0/n;
    for(int i=1;i<=d;i++){
        for(int j=1;j<=n;j++){
            if(j==x) continue;
            for(int k=0;k<edge[j].size();k++){
                int v = edge[j][k];
                if(v==x) continue;
                dp[j][i]+= dp[v][i-1]*1.0/edge[j].size();
            }
        }
    }
    double ans = 0;
    for(int i=1;i<=n;i++){
        if(i!=x) ans= ans+dp[i][d];
    }
    return ans;
}
int main(){
    int tcase;
    scanf("%d",&tcase);
    while(tcase--){
        scanf("%d%d%d",&n,&m,&d);
        for(int i=1;i<=n;i++) edge[i].clear();
        for(int i=1;i<=m;i++) {
            int u,v;
            scanf("%d%d",&u,&v);
            if(u==v) continue;
            edge[u].push_back(v);
            edge[v].push_back(u);
        }
        for(int i=1;i<=n;i++){
            memset(dp,0,sizeof(dp));
            printf("%.10lf\n",solve(i));
        }
    }
    return 0;
}

 

posted @ 2016-08-26 17:12  樱花庄的龙之介大人  阅读(206)  评论(0编辑  收藏  举报