poj 1979(dfs)

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 29990   Accepted: 16293

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

深搜要多练练。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<math.h>
#include<queue>
#include<iostream>
using namespace std;
typedef long long LL;
int m,n;
char graph[25][25];
bool vis[25][25];
int sx,sy,cnt;
int dir[][2] = {{1,0},{-1,0},{0,1},{0,-1}};
void dfs(int x,int y)
{
    vis[x][y] = true;
    cnt++;
    for(int i=0; i<4; i++)
    {
        int nextx = x+dir[i][0];
        int nexty = y+dir[i][1];
        if(nextx<0||nextx>=n||nexty<0||nexty>=m||vis[nextx][nexty]||graph[nextx][nexty]=='#') continue;
        dfs(nextx,nexty);
    }
    return ;
}
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF&&n+m)
    {
        cnt = 0;
        for(int i=0; i<n; i++)
        {
            scanf("%s",graph[i]);
            for(int j=0; j<m; j++)
            {
                if(graph[i][j]=='@')
                {
                    sx = i,sy=j;
                }
            }
        }
        memset(vis,false,sizeof(vis));
        dfs(sx,sy);
        printf("%d\n",cnt);

    }
    return 0;
}

 

posted @ 2016-06-10 16:49  樱花庄的龙之介大人  阅读(135)  评论(0编辑  收藏  举报