hdu 4496(并查集逆向添边)

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2933    Accepted Submission(s): 1038


Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

 

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
 

 

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

 

Sample Input
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 

 

Sample Output
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
 
 
 
题目大意:n个点(0-(n-1)) m条边,每次删除一条边,然后求每次剩下的连通分量
题解:先将m条边输入,然后反向添边(m-1->0)得到结果
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;

const int N = 10005;
const int M =100005;
int father[N];

int _find(int x){
    if(x==father[x]) return x;
    return father[x]=_find(father[x]);
}
struct Edge{
    int s,e;
}edge[M];
int a[M];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){

        for(int i=0;i<n;i++){
            father[i] = i;
        }
        for(int i=0;i<m;i++){
            scanf("%d%d",&edge[i].s,&edge[i].e);
        }
        a[m-1]=n;  ///最开始都是独立的点
        for(int i=m-1;i>0;i--){ ///从最后一条边开始添加
            int x = _find(edge[i].s);
            int y = _find(edge[i].e);
            if(x!=y){
                father[x] = y;
                a[i-1] = a[i]-1;
            }
            else a[i-1]=a[i];
        }
        for(int i=0;i<m;i++){
            printf("%d\n",a[i]);
        }
    }
    return 0;
}

 

posted @ 2016-03-28 20:15  樱花庄的龙之介大人  阅读(187)  评论(0编辑  收藏  举报