hdu 1829(继续扩展并查集)

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12944    Accepted Submission(s): 4215


Problem Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

 

Sample Input
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

 

Sample Output
Scenario #1: Suspicious bugs found!
Scenario #2: No suspicious bugs found!
这题还是找关系,然后套用公式 ,要注意的是这个题每组测试用例后面要多空一行。我标注的是relation[] 为0表示同性,1表示异性
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
const int N =2005;
int father[N];
int relation[N];  ///0表示同性,1表示异性

int _find(int x){
    if(x!=father[x]){
        int t = father[x];
        father[x] = _find(t);
        relation[x] = (relation[x]+relation[t])%2;
    }
    return father[x];
}
int main()
{
    int tcase;
    scanf("%d",&tcase);
    int k=1;
    while(tcase--){

        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++){
            father[i] = i;
            relation[i] = 0;
        }
        int flag = 0;
        for(int i=0;i<m;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            int roota = _find(a);
            int rootb = _find(b);
            if(roota==rootb){
                if(relation[a]==relation[b]) {  ///是同性
                    flag = 1;
                    continue;
                }
            }else{
                father[roota] = rootb;
                relation[roota] =(-relation[a]+relation[b]+1+2)%2; ///roota->rootb = roota->a+a->b+b->rootb
            }
        }
        printf("Scenario #%d:\n",(k++));
        if(flag) printf("Suspicious bugs found!\n");
        else printf("No suspicious bugs found!\n");
        printf("\n");
    }
    return 0;
}

 

 
 
 
posted @ 2016-03-28 16:50  樱花庄的龙之介大人  阅读(191)  评论(0编辑  收藏  举报