hdu 5023

A Corrupt Mayor's Performance Art

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 100000/100000 K (Java/Others)
Total Submission(s): 1866    Accepted Submission(s): 650


Problem Description
Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X's painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X's horse fart(In Chinese English, beating one's horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X's secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary's idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 .... color 30. The wall's original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn't know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?
 

 

Input
There are several test cases.

For each test case:

The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000)

Then M lines follow, each representing an operation. There are two kinds of operations, as described below:

1) P a b c
a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

2) Q a b
a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

Please note that the operations are given in time sequence.

The input ends with M = 0 and N = 0.
 

 

Output
For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 ... etc. And this color sequence must be in ascending order.
 

 

Sample Input
5 10 P 1 2 3 P 2 3 4 Q 2 3 Q 1 3 P 3 5 4 P 1 2 7 Q 1 3 Q 3 4 P 5 5 8 Q 1 5 0 0
 

 

Sample Output
4 3 4 4 7 4 4 7 8
 
和pku2777一样,练了下手,详解在 http://www.cnblogs.com/liyinggang/p/5304085.html
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<iostream>
using namespace std;

const int MAXSIZE = 1000000;
int sum;
struct Tree{
    int cover;
    int color;
    int l,r;
}tree[MAXSIZE<<2];

void pushUp(int idx){
    tree[idx].color = tree[idx<<1].color|tree[idx<<1|1].color;
}
void pushDown(int i){
    if(tree[i].cover){
         tree[i<<1].color=tree[i].color ;
         tree[i<<1|1].color=tree[i].color;
        tree[i<<1].cover = tree[i<<1|1].cover = 1;
        tree[i].cover = 0;
    }
}
void build(int l,int r,int idx){
    tree[idx].l = l;
    tree[idx].r = r;
    tree[idx].color =2;  //这个题和hdu 2777 没什么不同,就是要初始化为2 The wall's original color was color 2.
    tree[idx].cover = 1;
    if(l==r) return;
    int  mid = (l+r)>>1;
    build(l,mid,idx<<1);
    build(mid+1,r,idx<<1|1);
    pushUp(idx);
}
void update(int l,int r,int idx,int value){
    if(tree[idx].l>=l&&tree[idx].r<=r){
        tree[idx].color = value;
        tree[idx].cover = 1;
        return;
    }
    pushDown(idx);
    int mid = (tree[idx].l+tree[idx].r)>>1;
    if(r<=mid) update(l,r,idx<<1,value);
    else if(l>mid) update(l,r,idx<<1|1,value);
    else {
        update(l,mid,idx<<1,value);
        update(mid+1,r,idx<<1|1,value);
    }
    pushUp(idx);
}
void query(int l,int r,int idx){
     if(tree[idx].l>=l&&tree[idx].r<=r){
        sum|=tree[idx].color;
        return;
     }
     if(tree[idx].cover) {
        sum|=tree[idx].color;
        return;
     }
    int mid = (tree[idx].l+tree[idx].r)>>1;
    if(r<=mid) query(l,r,idx<<1);
    else if(l>mid) query(l,r,idx<<1|1);
    else {
        query(l,mid,idx<<1);
        query(mid+1,r,idx<<1|1);
    }
}
void solve(){
    int a[30];
    //printf("%d\n",sum);
    int k=0,t=0;
    while(sum){
       if(sum&1) a[k++] = t+1;
       t++;
       sum = sum>>1;
    }
    for(int i=0;i<k-1;i++) printf("%d ",a[i]);
    printf("%d\n",a[k-1]);
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m),n+m){
        build(1,n,1);
        while(m--){
            char s[5];
            scanf("%s",s);
            if(s[0]=='P'){
                int a,b,c;
                scanf("%d%d%d",&a,&b,&c);
                update(a,b,1,1<<(c-1));
            }else{
                int a,b;
                scanf("%d%d",&a,&b);
                sum = 0;
                query(a,b,1);
                solve();
            }
        }
    }
    return 0;
}

 

posted @ 2016-03-21 23:34  樱花庄的龙之介大人  阅读(374)  评论(0编辑  收藏  举报