hdu 1253 胜利大逃亡

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30371    Accepted Submission(s): 11380


Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

 

 

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

 

Sample Input
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

 

Sample Output
11
 看懂了题用BFS搜就能出来了,不过第一次超时,加了个判断才过,不过也是险而又险过的,1934MS,,没用JAVA写,出题人说数据卡的紧,怕超时。不过待会可以用JAVA试试
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#define N 51
using namespace std;

struct node{
    int x,y,z,time;
};
int Map[N][N][N];
bool vis[N][N][N];
int dir[6][3] = {{0,0,1},{0,1,0},{1,0,0},{-1,0,0},{0,-1,0},{0,0,-1}}; //上下左右前后六个方向
int A,B,C,T;
bool check(int x,int y,int z){
    if(x<0||x>A-1||y<0||y>B-1||z<0||z>C-1) return true;
    if(vis[x][y][z]||Map[x][y][z]==1) return true;
    return false;
}
void bfs(){
    queue<node> q;
    node t,next;
    t.x=0;
    t.y=0;
    t.z=0;
    t.time=0;
    vis[t.x][t.y][t.z]=true;
    q.push(t);
    while(!q.empty()){
        t = q.front();
        q.pop();
        if(t.time>T){ //不加这句会超时
            printf("-1\n");
            return;
        }
        if(t.x==A-1&&t.y==B-1&&t.z==C-1&&t.time<=T){
            printf("%d\n",t.time);
            return;
        }
        for(int i=0;i<6;i++){
            next.x = t.x+dir[i][0];
            next.y = t.y+dir[i][1];
            next.z = t.z+dir[i][2];
            next.time = t.time+1;
            if(check(next.x,next.y,next.z)) continue;
            q.push(next);
            vis[next.x][next.y][next.z]=true;
        }
    }
    printf("-1\n");
}
int main()
{
    int tcase;
    scanf("%d",&tcase);
    while(tcase--){
        memset(vis,false,sizeof(vis));
        memset(Map,0,sizeof(Map));
        scanf("%d%d%d%d",&A,&B,&C,&T);
        for(int i=0;i<A;i++){
            for(int j=0;j<B;j++){
                for(int k=0;k<C;k++){
                    scanf("%d",&Map[i][j][k]);
                }
            }
        }
        bfs();
    }
    return 0;
}

  java果断超时,附超时代码

import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;

public class Main {
	static boolean[][][] vis;
	static int[][][] map;
	static int[][] dir = {{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
	static int A,B,C,T;
	static class node{
		int x,y,z,time;
		public node(int x,int y,int z,int time){
			this.x=x;
			this.y=y;
			this.z=z;
			this.time=time;
		}
	}
	public static void main(String[] args) {
		Scanner sc =new Scanner(System.in);
		int tcase = sc.nextInt();
		while(tcase-->0){
			A=sc.nextInt();
			B=sc.nextInt();
			C=sc.nextInt();
			T=sc.nextInt();
			map = new int[A][B][C];
			vis = new boolean[A][B][C];
			for(int i=0;i<A;i++){
				for(int j=0;j<B;j++){
					for(int k=0;k<C;k++)
						map[i][j][k]=sc.nextInt();
				}
			}
		}
		BFS();
	}

	private static void BFS() {
		Queue<node> q =new LinkedList<node>();
		vis[0][0][0]=true;
		q.add(new node(0,0,0,0));
		while(!q.isEmpty()){
			node t = q.remove();
			if(t.time>T) {
				System.out.println(-1);
				return;
			}
			if(t.x==A-1&&t.y==B-1&&t.z==C-1&&t.time<=T){
				System.out.println(t.time);
				return;
			}
			for(int i=0;i<6;i++){
				int x = t.x+dir[i][0];
				int y =t.y+dir[i][1];
				int z = t.z +dir[i][2];
				int time = t.time+1;
				if(check(x,y,z)) continue;
				q.add(new node(x,y,z,time));
				vis[x][y][z]=true;
			}
		}
		System.out.println(-1);
	}

	private static boolean check(int x, int y, int z) {
		if(x<0||x>A-1||y<0||y>B-1||z<0||z>C-1) return true;
		if(vis[x][y][z]||map[x][y][z]==1) return true;
		return false;
	}

}

  

 

posted @ 2015-12-11 21:16  樱花庄的龙之介大人  阅读(310)  评论(0编辑  收藏  举报