HDU--3635 带权并查集

地址:http://acm.hdu.edu.cn/showproblem.php?pid=3635

Dragon Balls

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 
Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 
Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
 
Sample Output
Case 1:
2 3 0
Case 2:
2 2 1 3 3 2
 
    题意:给出N个龙珠,i龙珠在i城市。T:x,y。将x所在集合放y上。Q: x。查询x所在集合的:x所在集合;x所在集合的元素总数;x被移动次数。
    解析:x所在集合,直接查找其根节点即可。x所在集合元素数:直接加入all[]数组在合并的时候进行维护。
      重要的是x被移动次数怎么算。样例2来讲,1 2 ,1 3。1放在2树上,再要连接1 3,实际上是2连接3,tim[2]++,但是tim[1]并没有改变。所以要在find()里加入tim值的更新:tim[x]+=tim[pr[x]]。本节点的移动次数,是本身+根节点的移动次数。即向上回溯祖先,要将转移次数加给子孙。而且本代码是有点先斩后奏的意思,就是join()里tim[fa]先++,fa的子孙的tim[],留给下次操作来更新。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<set>
using namespace std;
const int maxn=2e4+10;
int pr[maxn],all[maxn],tim[maxn];
int n,m;
void init()
{
    for(int i=1;i<=n;i++)
    {
        pr[i]=i;
        all[i]=1;
        tim[i]=0;
    }
}
int find(int x)
{
    if(x==pr[x])
        return x;
    int fa=pr[x];
    pr[x]=find(pr[x]);
    tim[x]+=tim[fa];
    return pr[x];
}
void join(int a,int b)
{
    int fa=find(a),fb=find(b);
    if(fa!=fb)
    {
        pr[fa]=fb;
        all[fb]+=all[fa];
        tim[fa]++;
    }
    return ;
}
int main()
{
    int t;
    int ac=1;
    scanf("%d",&t);
    while(t--)
    {
        printf("Case %d:\n",ac++);
        scanf("%d%d",&n,&m);
        init();
        char ch[5];
        while(m--)
        {
        //    scanf("%c",&ch);
            scanf("%s",ch);    
            int x,y;            
            if(ch[0]=='T')
            {
                scanf("%d%d",&x,&y);
                join(x,y);
            }
            else
            {
                scanf("%d",&x);
                int mid=find(x);
                cout<<mid<<" "<<all[mid]<<" "<<tim[x]<<endl;
            }
        }
    }
}

 

posted @ 2020-04-06 22:02  liyexin  阅读(126)  评论(0编辑  收藏  举报