Nagios排错

Nagios错误集合

类型一:NRPE: Command 'check_swap' not defined

会出现这个错误是因为主控端在检查linux被控端的check_swap这个命令的时候,发现没有被定义。
说明一点:
            如果主控段和被控都配置好的情况下,主控端要实现多项监控的时候,主控端的nrpe.cfg是不用进行配置的,而需要进行配置的就是被控端的nrpe.cfg
其中需要注意的地方:
1.在主控端写被控端的定义配置文件的时候(比如nagios.cfg这样的配置文件)里面所定义的命令行最好跟被控端的nrpe.cfg里面要添加的命令行的命令一样。
例如:
define service{
        use                                     linux               ; Name of service template to use
        host_name                        linux-node1.liyang.me
        service_description           Swap Usage
        check_command                  check_nrpe!check_swap!20!10
        }
那么其中“check_swap”这个nrpe的命令名称要和被控端的nrpe.cfg的配置文件里面的命令行里的“check_swap”相同。
command[check_swap]=/usr/local/nagios/libexec/check_swap -w 20% -c 10%

2.更改完配置记得重启nrpe

ps -ef |grep nrpe  查看进程

pkill nrpe  关闭

/usr/local/nagios/bin/nrpe -c /usr/local/nagios/etc/nrpe.cfg -d   启动

类型二:Nagios HTTP WARNING: HTTP/1.1 403 Forbidden

解决方法:

touch /var/www/html/index.html
重启httpd和nagios服务,等待几分钟警告就自动清除了。

/etc/init.d/nagios restart
/etc/init.d/httpd restart

类型三:httpd: apr_sockaddr_info_get() failed for nagios

原因:这个问题应该是没有在 /etc/httpd/conf/httpd.conf 中设定 ServerName。所以apache会用主机上的名称来取代,首先会去找 /etc/hosts 中有没有主机的定义。

解决办法:

(1)可以设定httpd.conf文件中的 ServerName,如下:ServerName localhost:80 ? ? ? ? ? ? ? ? ? ? ? ?

(2)在 /etc/hosts 中填入自己的主机名称 nagios,如下:127.0.0.1 nagios (主机名称)

posted on 2016-03-18 23:22  曦字号  阅读(165)  评论(0)    收藏  举报

导航