CentOS 6.5 64位下安装Redis
CentOS 6.5 64位下安装Redis
系统环境:CentOS 6.5 64位
安装方式:编译安装
防火墙:开启
Redis版本:Redis 3.0.2
一、环境准备
1、安装 gcc gcc-c++
[root@iZ94ebgv853Z ~]# yum install gcc gcc-c++ -y
2、下载redis-3.0.2.tar.gz
[root@iZ94ebgv853Z ~]# wget http://download.redis.io/releases/redis-3.0.2.tar.gz
二、安装Redis
[root@iZ94ebgv853Z ~]# tar xf redis-3.0.2.tar.gz #解压
[root@iZ94ebgv853Z ~]# cd redis-3.0.2
[root@iZ94ebgv853Z redis-3.0.2]# make
[root@iZ94ebgv853Z redis-3.0.2]# make test
报错如下:
cd src&& make test
make[1]:Entering directory `/root/redis-3.0.2/src'
You needtcl 8.5 or newer in order to run the Redis test
make[1]:*** [test] Error 1
make[1]:Leaving directory `/root/redis-3.0.2/src'
make: *** [test] Error 2
原因:需要安装tcl
[root@iZ94ebgv853Zredis-3.0.2]# yum install tcl –y
[root@iZ94ebgv853Z redis-3.0.2]# make test
[root@iZ94ebgv853Zredis-3.0.2]# cp redis.conf /etc/ #复制配置文件
如果需自定义配置redis,可修改其配置文件/etc/redis.conf
三、启动redis
[root@iZ94ebgv853Z ~]# redis-server /etc/redis.conf
四、设置防火墙
|
###################################### # Firewall configuration written bysystem-config-firewall # Manual customization of this file is notrecommended. *filter :INPUT ACCEPT [0:0] :FORWARD ACCEPT [0:0] :OUTPUT ACCEPT [0:0] -A INPUT -m state --stateESTABLISHED,RELATED -j ACCEPT -A INPUT -p icmp -j ACCEPT -A INPUT -i lo -j ACCEPT -A INPUT -m state --state NEW -m tcp -p tcp--dport 22 -j ACCEPT -A INPUT -j REJECT --reject-withicmp-host-prohibited -A FORWARD -j REJECT --reject-withicmp-host-prohibited COMMIT ##################################### |
把文本框内容写入到/etc/sysconfig/iptables,覆盖原来的内容(如果有的话)。
[root@iZ94ebgv853Z ~]# service iptables start #启动防火墙
[root@iZ94ebgv853Z ~]# iptables -I INPUT 1 -p tcp --dport6379 -j ACCEPT #开启6379端口
[root@iZ94ebgv853Z ~]# service iptables save #保存防火墙的配置
五、设置开机启动
[root@iZ94ebgv853Z~]# chkconfig iptables on #设置iptables开机启动
设置redis开机启动:
在/etc/rc.local中添加:/usr/local/bin/redis-server /etc/redis.conf > /dev/null &

浙公网安备 33010602011771号