HDU1159最长公共子序列

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20061    Accepted Submission(s): 8571


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

 

Sample Output
4 2 0

 

#include<iostream>
#include<algorithm>
#include<string>
#define MAX 1000
using namespace std;
int a[MAX][MAX];
int main()
{
    string s1, s2;
    while (cin >> s1 >> s2){
        memset(a, 0, sizeof(a));
        for (int i = 0; i <s1.length();i++){
            for (int j = 0; j < s2.length();j++){
                if (s1[i] == s2[j]){
                    a[i + 1][j + 1] = a[i][j] + 1;
                }
                else{
                    a[i + 1][j + 1] = max(a[i][j + 1], a[i + 1][j]);
                }
            }
        }
        cout << a[s1.length()][s2.length()] << endl;
    }
    //system("pause");
    return 0;
}

 

posted @ 2014-02-15 20:37  偶尔会寂寞  阅读(143)  评论(0编辑  收藏  举报