dyld: Library not loaded: /usr/local/opt/openssl/lib/libcrypto.1.0.0.dylib 解决方案

运行PHPcomposer...提示dyld: Library not loaded: /usr/local/opt/openssl/lib/libcrypto.1.0.0.dylib

PHP 错误展示
$ php -v
dyld: Library not loaded: /usr/local/opt/openssl/lib/libcrypto.1.0.0.dylib
Referenced from: /usr/local/bin/php
Reason: image not found
[1] 6970 abort php -v

解决方法
brew switch openssl 1.0.2o_1(版本号)

posted @ 2020-01-19 16:14  littleBit  阅读(5758)  评论(0编辑  收藏  举报