Bad Hair Day-POJ3250(简单的入栈出栈)

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ h≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

我本来用递归写的 现在发现好笨啊
简单的栈就可以
题目大意:

给你n个数,求每个数后面比他小的个数和

这个题是先把第一个a[0]入栈 再开始判断a[i]和入栈内的
如果栈顶的呢一个数比a[i]大 说明a[i]可以被栈内的每一个数看到然后就可以直接加上栈的长度。
然后再把a[i]入栈。
#include<stdio.h>
#include<stack>
#include<iostream>
#include<string.h>
using namespace std;
#define N 88000
stack<int >Q;
int a[N];
int main()
{
    int n,i;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        Q.push(a[1]);
        long long ans=0;
        for(i=2;i<=n;i++)
        {
            while(!Q.empty() && Q.top()<=a[i])
                Q.pop();
            ans+=Q.size();
            Q.push(a[i]);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

posted @ 2015-11-14 17:55  啦咯  阅读(196)  评论(0编辑  收藏  举报