HDU-1021 Fibonacci Again

Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

 

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

 

Sample Input

0

1

2

3

4

5

 

Sample Output

no

no

yes

no

no

no


 

与 HDU-1005 类似。

#include <iostream>
using namespace std;

int main(void)
{
    int n;
    
    while(cin >> n)
    {
        
        if(n%4 == 2)
            cout << "yes" << endl;
        else
            cout << "no" << endl;
    }
    
    return 0;
}

 

posted @ 2017-04-12 22:32  limyel  阅读(118)  评论(0编辑  收藏  举报