iOS——Command-Line 查看当前SDK版本并修改默认SDK版本

在工作中可能会碰到用命令行编译、打包iOS应用程序的情况(xcodebuild相关命令)。

但是由于SDK版本问题,会报错,说某SDK版本不对,可能是因为升级Xcode导致的SDK版本升级,为了避免高SDK版本对当前代码的稳定性,可以通过修改默认SDK版本来解决。前提是,你需要安装了响应的SDK版本,一般xcode会自带SDK,比如下载就版本的Xcode,就会带有旧版本的SDK。

 

查看SDK版本命令:

xcodebuild -showsdks

显示如下:

  

修改sdk版本

$ sudo xcode-select -switch /Applications/Xcode_2.app(前提是我已经安装了xcode5.1.1版本,并命名为Xcode_2)

再次运行xcodebuild -showsdks 会看到:

 

希望能帮助到大家

 

posted @ 2015-04-09 10:46 lihaiyin 阅读(...) 评论(...) 编辑 收藏