POJ 1584:A Round Peg in a Ground Hole

A Round Peg in a Ground Hole
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5741   Accepted: 1842

Description

The DIY Furniture company specializes in assemble-it-yourself furniture kits. Typically, the pieces of wood are attached to one another using a wooden peg that fits into pre-cut holes in each piece to be attached. The pegs have a circular cross-section and so are intended to fit inside a round hole. 
A recent factory run of computer desks were flawed when an automatic grinding machine was mis-programmed. The result is an irregularly shaped hole in one piece that, instead of the expected circular shape, is actually an irregular polygon. You need to figure out whether the desks need to be scrapped or if they can be salvaged by filling a part of the hole with a mixture of wood shavings and glue. 
There are two concerns. First, if the hole contains any protrusions (i.e., if there exist any two interior points in the hole that, if connected by a line segment, that segment would cross one or more edges of the hole), then the filled-in-hole would not be structurally sound enough to support the peg under normal stress as the furniture is used. Second, assuming the hole is appropriately shaped, it must be big enough to allow insertion of the peg. Since the hole in this piece of wood must match up with a corresponding hole in other pieces, the precise location where the peg must fit is known. 
Write a program to accept descriptions of pegs and polygonal holes and determine if the hole is ill-formed and, if not, whether the peg will fit at the desired location. Each hole is described as a polygon with vertices (x1, y1), (x2, y2), . . . , (xn, yn). The edges of the polygon are (xi, yi) to (xi+1, yi+1) for i = 1 . . . n − 1 and (xn, yn) to (x1, y1).

Input

Input consists of a series of piece descriptions. Each piece description consists of the following data: 
Line 1 < nVertices > < pegRadius > < pegX > < pegY > 
number of vertices in polygon, n (integer) 
radius of peg (real) 
X and Y position of peg (real) 
n Lines < vertexX > < vertexY > 
On a line for each vertex, listed in order, the X and Y position of vertex The end of input is indicated by a number of polygon vertices less than 3.

Output

For each piece description, print a single line containing the string: 
HOLE IS ILL-FORMED if the hole contains protrusions 
PEG WILL FIT if the hole contains no protrusions and the peg fits in the hole at the indicated position 
PEG WILL NOT FIT if the hole contains no protrusions but the peg will not fit in the hole at the indicated position

Sample Input

5 1.5 1.5 2.0
1.0 1.0
2.0 2.0
1.75 2.0
1.0 3.0
0.0 2.0
5 1.5 1.5 2.0
1.0 1.0
2.0 2.0
1.75 2.5
1.0 3.0
0.0 2.0
1

Sample Output

HOLE IS ILL-FORMED
PEG WILL NOT FIT

题意是按照一定顺序(顺时针或是逆时针)给定一些点,问这些点组成的图形是不是凸包。如果不是,输出“HOLE IS ILL-FORMED”。如果是,又有一个圆,问该圆是否在凸包里面。在里面,输出“PEG WILL FIT”。不在里面,输出“PEG WILL NOT FIT”。


自己对于输入过来的点,就看输入过来的点 叉积 是不是一直大于零,或是一直小于零。

然后对于圆心是不是在凸包里面,我的判断方法是计算面积。如果以圆心、凸包上的两个点为三条形的面积总和与凸包的总面积相等,那这个点一定在凸包里面。否则就在外面。

至于半径那部分,就是计算点到直线的距离,判断与半径之间的关系。

折磨了我整整一个上午。。。


代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

struct no
{
	double x, y;
}node[2005], peg, orign;

int n;
double peg_r;

double dis(no n1, no n2)
{
	if (n1.x == n2.x)
	{
		return fabs(n1.x - peg.x);
	}
	else
	{
		double k = (n2.y - n1.y) / (n2.x - n1.x);
		double b = n2.y - k*n2.x;
		return fabs(k*peg.x - peg.y + b) / sqrt(k*k + 1);
	}
}

double xmult(double x1, double y1, double x2, double y2)
{
	return x1*y2 - x2*y1;
}

double Across(no n1, no n2, no n3, no n4)
{
	return xmult(n2.x - n1.x, n2.y - n1.y, n4.x - n3.x, n4.y - n3.y);
}

bool convex()
{
	int i;
	double res, sign = 0;
	for (i = 0; i < n; i++)
	{
		res = Across(node[i%n], node[(i + 1) % n], node[(i + 1) % n], node[(i + 2) % n]);
		if (sign == 0)
		{
			sign = res;
		}
		else if (sign > 0)
		{
			if (res < 0)
				return true;
		}
		else if (sign < 0)
		{
			if (res > 0)
				return true;
		}
	}
	return false;

}

int main()
{
	int i, pos_x;
	double min_x;

	while (cin >> n)
	{
		if (n < 3)
			break;
		cin >> peg_r >> peg.x >> peg.y;
		min_x = 100005;

		for (i = 0; i < n; i++)
		{
			cin >> node[i].x >> node[i].y;
			if (node[i].x < min_x)
			{
				min_x = node[i].x;
				pos_x = i;
			}
			else if (min_x == node[i].x&&node[i].y < node[pos_x].y)
			{
				pos_x = i;
			}
		}
		orign = node[pos_x];

		if (convex())
		{
			cout << "HOLE IS ILL-FORMED" << endl;
		}
		else
		{
			int sign = 1;
			double sum1 = 0;
			for (i = 0; i<n; ++i)
			{
				sum1 += fabs(((node[i%n].x - node[1].x) * (node[(i + 1) % n].y - node[1].y) - (node[i%n].y - node[1].y) * (node[(i + 1) % n].x - node[1].x)));
			}

			double sum2 = 0;

			for (i = 0; i < n; ++i)
			{
				sum2 += fabs(((node[i%n].x - peg.x) * (node[(i + 1) % n].y - peg.y) - (node[i%n].y - peg.y) * (node[(i + 1) % n].x - peg.x)));
			}

			if (sum1 == sum2)
			{
				sign = 0;
			}

			if (sign == 1)
			{
				cout << "PEG WILL NOT FIT" << endl;
			}
			else
			{
				double len;
				sign = 0;
				for (i = 0; i < n; i++)
				{
					len = dis(node[i%n], node[(i + 1) % n]);
					if (len < peg_r)
					{
						sign = 1;
						break;
					}
				}
				if (sign == 1)
				{
					cout << "PEG WILL NOT FIT" << endl;
				}
				else
				{
					cout << "PEG WILL FIT" << endl;
				}
			}
		}
	}

	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on 2015-09-23 17:01  光速小子  阅读(139)  评论(0编辑  收藏  举报

导航