POJ 1852:Ants

Ants
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 11754   Accepted: 5167

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

很有趣的一道题目,说的是在一个水平线上有很多个蚂蚁,蚂蚁走到端点就下落,蚂蚁两两相碰的话就掉头走,问最少蚂蚁都下落的时间和最多蚂蚁都下落的时间。

因为蚂蚁的速度都相同,所以相遇即是不相遇,完全可以看成是各走各的,不影响。这样思路的话,瞬间就简单很多了。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;

int main()
{
	int test;
	cin>>test;

	while(test--)
	{
		int length,ant;
		int min_val=-1,max_val=-1;
		cin>>length>>ant;

		while(ant--)
		{
			int dis;
			cin>>dis;
			min_val=max(min_val,min(dis,length-dis));
			max_val=max(max_val,max(dis,length-dis));
		}
		cout<<min_val<<" "<<max_val<<endl;
	}
	return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on 2015-06-30 11:03  光速小子  阅读(131)  评论(0编辑  收藏  举报

导航