随笔分类 - Linux
Linux . Lnmp , GIt
摘要:一、从http://pecl.php.net/上下载相应的扩展包,可以通过wget获取 二、解压扩展包 三、进入该解压后的目录 这里需要查找php-config的所在,我用的是lnmp,默认安装在以上路径中 四、在php.ini中进行配置 加入 五、重启php
阅读全文
摘要:1、为什么使用redis 使用redis,主要是从两个角度去考虑:性能和并发。当然,redis还具备可以做分布式锁等其他功能,但是如果只是为了分布式锁这些其他功能,完全还有其他中间件(如zookpeer等)代替,并不是非要使用redis。因此,这个问题主要从性能和并发两个角度去答。 回答:如下所示,
阅读全文
摘要:安装完Centos7最小化后,需要再做一些操作,安装其他的一些软件 1、centos7没有ifconfig命令,可以用下命令查看ip 如果要安装ifconfig命令,可以使用 2、关闭centos7自带的防火墙firewall 启用iptable (1)停止Firewall 关闭firewall自动
阅读全文
摘要:一、创建新用户,并且设置目录,禁止shell登录 nologin要事先确认位置,通常在/usr/sbin或/sbin下(可在/etc/passwd中查看sshd的nologin配置) 二、设置用户密码 三、将该用户目录所有者设置成root 四、修改/etc/ssh/sshd_config文件 五、重
阅读全文
摘要:一、修改表 二、授权 三、可能需要开放端口或者关闭防火墙 centos7版本对防火墙进行加强,不再使用原来的iptables,启用firewall #通过systemctl status firewalld查看firewalld状态#FirewallD is not runningsystemctl
阅读全文
摘要:主要使用PHP imagick扩展,以及ImageMagick软件进行转换 一、安装ImageMagick Centos下可以直接使用 然后再安装ImageMagick-devel,否则php安装扩展时会报错 configure: error: not found. Please provide a
阅读全文
摘要:一、使用openoffice跟unoconv进行转换 二、安装openoffice,安装包可以从官网下载(Apache_OpenOffice_4.1.5_Linux_x86-64_install-rpm_zh-CN.tar.gz) 解压,安装(解压后会有一个zh-CN的文件夹): 注:这里可能需要安
阅读全文
摘要:一、发布消息类(client.php),发布者 二、接受消息类(server.php),订阅者 三、需要将订阅者常驻于后台进程。 这里先使用下命令 然后打开另一个终端,使用
阅读全文
摘要:背景:本地已有一个项目,部署在本地环境中,需要将项目做git版本控制处理,上传到github或者git服务器上 一、进入项目根目录,运行一下命令,创建一个git可管理的仓库 二、提交仓库 三、在本地(linux)运行以下命令,生成公钥 /root/.ssh/ id_rsa.pub 和 私钥 /roo
阅读全文
摘要:2018-08-14修改: 在lnmp1.5下遇到问题,路径定到public目录中,出现500的问题 解决办法:将nginx配置目录中的 fastcgi.conf 配置文件 中的 fastcgi_param PHP_ADMIN_VALUE "open_basedir=$document_root/:
阅读全文

浙公网安备 33010602011771号