九度OJ 1002:Grading

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:18410

解决:4753

题目描述:

    Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
    For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
    • A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.
    • If the difference exceeds T, the 3rd expert will give G3.
    • If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.
    • If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.
    • If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

    Each input file may contain more than one test case.
    Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

    For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0
来源:
2011年浙江大学计算机及软件工程研究生机试真题
思路:

基本的单个数据处理题,主要考察分支判断代码撰写。


代码:

#include <stdio.h>
#include <stdlib.h>
 
#define N 1000
 
double t;
 
double aver(double a, double b)
{
    return (a+b)/2;
}
 
int tol(double i, double j)
{
    return abs(i-j)<=t;
}
 
double max(double a, double b, double c)
{
    a = (a>b) ? a : b;
    a = (a>c) ? a : c;
    return a;
}
 
int main(void)
{
    double p, g1, g2, g3, gj;
    double score;
 
    while (scanf("%lf", &p) != EOF)
    {
        scanf("%lf%lf%lf%lf%lf", &t, &g1, &g2, &g3, &gj);
 
        if (tol(g1, g2))
            score = aver(g1, g2);
        else if (tol(g1, g3) && tol(g2, g3))
            score = max(g1, g2, g3);
        else if (tol(g1, g3))
            score = aver(g1, g3);
        else if (tol(g2, g3))
            score = aver(g2, g3);
        else
            score = gj;
        printf("%.1lf\n", score);
    }
 
    return 0;
}
/**************************************************************
    Problem: 1002
    User: liangrx06
    Language: C
    Result: Accepted
    Time:0 ms
    Memory:912 kb
****************************************************************/


posted on 2015-10-14 22:08  梁山伯  阅读(144)  评论(0编辑  收藏  举报

导航