九度OJ 1124:Digital Roots(数根) (递归)

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:2963

解决:1066

题目描述:

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

输入:

    The input file will contain a list of positive integers, one per line. 
    The end of the input will be indicated by an integer value of zero.

输出:

    For each integer in the input, output its digital root on a separate line of the output.

样例输入:
24
39
0
样例输出:
6
3
提示:

The integer may consist of a large number of digits.

来源:
2008年北京大学方正实验室计算机研究生机试真题

思路:

递归,结束条件是仅剩一位数。主要考察数位的分解。


代码:

#include <stdio.h>
#include <string.h>
 
#define M 1000000
 
int main(void)
{
    long long a, b;
    char s[M+1];
    int i;
 
    while (scanf("%s", s) != EOF)
    {
        if (strcmp(s, "0") == 0)
            break;
 
        a = 0;
        for (i=0; s[i]; i++)
            a += s[i]-'0';
 
        while (a>=10)
        {
            b = 0;
            while (a)
            {
                b += a%10;
                a /= 10;
            }
            a = b;
        }
 
        printf("%lld\n", a);
    }
 
    return 0;
}
/**************************************************************
    Problem: 1124
    User: liangrx06
    Language: C
    Result: Accepted
    Time:10 ms
    Memory:1816 kb
****************************************************************/



posted on 2015-10-24 10:24  梁山伯  阅读(278)  评论(0编辑  收藏  举报

导航