Day of Week

题目1043:Day of Week

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:1544

解决:609

题目描述:

We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入:

There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

输出:

Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

样例输入:
9 October 2001
14 October 2001
样例输出:
Tuesday
Sunday
提示:

Month and Week name in Input/Output:
January, February, March, April, May, June, July, August, September, October, November, December
Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday



#include <iostream>
#include <map>
#include <string>
using namespace std;

int main(void)
{
	int days[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31,30, 31};
	map<string, int>Month;
	int day, year, month, sumDay;
	string strMonth;
	Month.insert(make_pair("January",   1));
	Month.insert(make_pair("February",  2));
	Month.insert(make_pair("March",     3));
	Month.insert(make_pair("April",     4));
	Month.insert(make_pair("May",       5));
	Month.insert(make_pair("June",      6));
	Month.insert(make_pair("July",      7));
	Month.insert(make_pair("August",    8));
	Month.insert(make_pair("September", 9));
	Month.insert(make_pair("October",  10));
	Month.insert(make_pair("November", 11));
	Month.insert(make_pair("December", 12));

	while (cin >> day >> strMonth >> year)
	{
		sumDay = 0;
		month = Month[strMonth];
		for (int i = 1; i <= year - 1; i++)
		{
			if ((i % 4 == 0 && i % 100 != 0) || i % 400 == 0)
			{
				sumDay += 366;
			}
			else
			{
				sumDay += 365;
			}
		}
		if ((year % 4 == 0 && year % 100 != 0) || year % 400 == 0)
		{
			days[2] = 29;
		}
		else
		{
			days[2] = 28;
		}
		for (int i = 1; i <= month - 1; i++)
		{
			sumDay += days[i];
		}
		sumDay += day;

		sumDay = sumDay % 7;
		switch (sumDay)
		{
		case 1:
			cout << "Monday" << endl;
			break;
		case 2:
			cout << "Tuesday" << endl;
			break;
		case 3:
			cout << "Wednesday" << endl;
			break;
		case 4:
			cout << "Thursday" << endl;
			break;
		case 5:
			cout << "Friday" << endl;
			break;
		case 6:
			cout << "Saturday" << endl;
			break;
		case 0:
			cout << "Sunday" << endl;
			break;
		default:
			break;
		}
	}
	return 0;
}


posted @ 2013-12-19 18:52  N3verL4nd  阅读(215)  评论(0编辑  收藏  举报