python3 tensorflow 安装

mac python3 安装tensorflow出错:futures requires Python '>=2.6, <3' but the running Python is 3.5.3




Same problem here on Ubuntu 16.04 with Python 3.5.
Clearly, Python 3 doesn't need futures. And with Python 2.7, using :
pip2 install tensorflow-gpu==1.5.0
it goes well.
Here's a solution for Python 3:
The error is occurred when installing the version of futures 3.2.0 for Python 3. It is noticed that:

It should not be installed on Python 3, although there should be no harm in doing so, as the standard library takes precedence over third party libraries.

First, install futures 3.1.1:

pip3 install futures==3.1.1
then :
pip3 install tensorflow-gpu==1.5.0
Do not add the --ignore-installed or -I


posted @ 2018-01-30 19:54 leo_23 阅读(...) 评论(...) 编辑 收藏