欢迎来到我的博客!

导航

关于 下载 nfs-utils时的 gssproxy conflicts with selinux-policy-3.13.1-102.el7.noarch 错误

使用 yum install nfs-utils -y 时 

出现如下错误:



错误:gssproxy conflicts with selinux-policy-3.13.1-102.el7.noarch
 您可以尝试添加 --skip-broken 选项来解决该问题
** 发现 6 个已存在的 RPM 数据库问题, 'yum check' 输出如下:
libselinux-2.5-14.1.el7.x86_64 是 libselinux-2.5-6.el7.x86_64 的副本
libselinux-utils-2.5-14.1.el7.x86_64 是 libselinux-utils-2.5-6.el7.x86_64 的副本
libsemanage-2.5-14.el7.x86_64 是 libsemanage-2.5-4.el7.x86_64 的副本
libsepol-2.5-10.el7.x86_64 是 libsepol-2.5-6.el7.x86_64 的副本
policycoreutils-2.5-29.el7_6.1.x86_64 是 policycoreutils-2.5-8.el7.x86_64 的副本
selinux-policy-3.13.1-229.el7_6.12.noarch 是 selinux-policy-3.13.1-102.el7.noarch 的副本



解决方法:

首先:

yum install yum-utils -y

然后执行命令:

package-cleanup --cleandupes -y

如果还存在如下错误:

Not removing selinux-policy-3.13.1-102.el7.noarch because it is required by 2 installed packages
Not removing libselinux-2.5-6.el7.x86_64 because it is required by 1 installed package
There are unfinished transactions remaining. You might consider running yum-complete-transaction,
or "yum-complete-transaction --cleanup-only" and "yum history redo last", first to finish them.
If those don't work you'll have to try removing/installing packages by hand (maybe package-cleanup can help). 再执行命令: package-cleanup --cleandupes with --removenewestdupes -y 之后重新下载即可 yum install nfs-utils -y

 

posted on 2019-05-13 09:49  leeeeel  阅读(2973)  评论(0编辑  收藏  举报