poj 2151 Check the difficulty of problems(概率DP)

Check the difficulty of problems
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4680   Accepted: 2049

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972


ans = (1-第1队做出0题)*(1-第2队做出0题)...(1-第n队做出0题)-(第1队做1-N题)*(第2队做1-N题)...(第n队做1-N题)

蓝色部分为条件1,红色部分为条件2.

dp[t][m][i]表示第t队在前m题中做出i题:

dp[t][m][i] = dp[t][m-1][i-1]*P[m][i]+dp[t][m-1][i]*(1-P[m][i]),i>0

dp[t][m][i] = dp[t][m-1][i]*(1-P[m][i]),i==0.


#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <cstdlib>
using namespace std;

const int maxt = 1010;
const int maxm = 35;
double dp[maxt][maxm][maxm] , P[maxt][maxm];
int N , M , T;

void initial(){
	for(int i = 0; i < maxt; i++){
		for(int j = 0; j < maxm; j++){
			P[i][j] = 0;
			for(int k = 0; k < maxm; k++) dp[i][j][k] = 0;
		}
	}
}

void readcase(){
	for(int i = 1; i <= T; i++){
		for(int j = 1; j <= M; j++) scanf("%lf" , &P[i][j]);
	}
}

void computing(){
	for(int i = 0; i <= T; i++) dp[i][0][0] = 1.0;
	for(int t = 1; t <= T; t++){
		for(int m = 1; m <= M; m++){
			for(int i = 0; i <= min(m , N); i++){
				if(i)dp[t][m][i] = dp[t][m-1][i-1]*P[t][m]+dp[t][m-1][i]*(1.0-P[t][m]);
				else dp[t][m][i] = dp[t][m-1][i]*(1.0-P[t][m]);
			}
		}
	}
	double ans = 1.0;
	for(int i = 1; i <= T; i++) ans = ans*(1.0-dp[i][M][0]);
	//cout << ans << endl;
	double tem = 1.0;
	for(int t = 1; t <= T; t++){
		double ttem = 0.0;
		for(int i = 1; i < N; i++) ttem += dp[t][M][i];
		tem *= ttem;
	}
	printf("%.3lf\n" , ans-tem);
}

int main(){
	while(scanf("%d%d%d", &M , &T , &N) && (N!=0 || M!=0 || T!=0)){
		initial();
		readcase();
		computing();
	}
	return 0;
}


posted @ 2016-03-25 11:26  lcchuguo  阅读(284)  评论(0编辑  收藏  举报