POJ1087 A Plug for UNIX 【最大流】

A Plug for UNIX
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13855   Accepted: 4635

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible. 
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling 
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can. 
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug. 
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric 
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1

Source

题意:给定一些插座,用电器,转换器。每一个插座仅仅能插一个用电器或者转换器,每一个用电器仅仅能插一个插座或者转换器,转换器有无数个。求最少有多少个用电器不能用上电。

题解:难在构图上,构图时须要注意节点数可能超出题目给定的范围。所以数组须要开大点。直接翻一倍。然后是map映射时须要避免反复或者掉漏。虚拟源点连向每一个用电器,容量为1。用电器连向插座或者转换器,容量为1。转换器连向插座。容量为inf,插座连向虚拟汇点。容量为1.

#include <stdio.h>
#include <string.h>
#include <string>
#include <map>

#define maxn 1010
#define maxm maxn * maxn << 1
#define maxs 30
#define inf 0x3f3f3f3f

int n, m, k, source, sink, num;
char str[maxs], buf[maxs];
std::map<std::string, int> mp;
int head[maxn], id;
struct Ndoe {
	int u, v, c, next;
} E[maxm];
int dep[maxn], ps[maxn], cur[maxn];

void addEdge(int u, int v, int c) {
	E[id].u = u; E[id].v = v;
	E[id].c = c; E[id].next = head[u];
	head[u] = id++;

	E[id].u = v; E[id].v = u;
	E[id].c = 0; E[id].next = head[v];
	head[v] = id++;
}

void getMap() {
	int i; id = 0; num = 3;
	source = 1; sink = 2;
	memset(head, -1, sizeof(head));
	scanf("%d", &n);
	for(i = 0; i < n; ++i) {
		scanf("%s", str);
		if(mp[str] == 0) mp[str] = num++;
		addEdge(mp[str], sink, 1);
	}
	scanf("%d", &m);
	for(i = 0; i < m; ++i) {
		scanf("%s%s", str, buf);
		mp[str] = num++;
		if(mp[buf] == 0) mp[buf] = num++;
		addEdge(mp[str], mp[buf], 1);
		addEdge(source, mp[str], 1);
	}
	scanf("%d", &k);
	for(i = 0; i < k; ++i) {
		scanf("%s%s", str, buf);
		if(mp[str] == 0) mp[str] = num++;
		if(mp[buf] == 0) mp[buf] = num++;
		addEdge(mp[str], mp[buf], inf);
	}
}

int Dinic(int n, int s, int t) {
    int tr, res = 0;
    int i, j, k, f, r, top;
    while(true) {
        memset(dep, -1, n * sizeof(int));
        for(f = dep[ps[0] = s] = 0, r = 1; f != r; )
            for(i = ps[f++], j = head[i]; j != -1; j = E[j].next) {
                if(E[j].c && -1 == dep[k=E[j].v]) {
                    dep[k] = dep[i] + 1; ps[r++] = k;
                    if(k == t) {
                        f = r; break;
                    }
                }
            }
        if(-1 == dep[t]) break;

        memcpy(cur, head, n * sizeof(int));
        for(i = s, top = 0; ; ) {
            if(i == t) {
                for(k = 0, tr = inf; k < top; ++k)
                    if(E[ps[k]].c < tr) tr = E[ps[f=k]].c;
                for(k = 0; k < top; ++k)
                    E[ps[k]].c -= tr, E[ps[k]^1].c += tr;
                res += tr; i = E[ps[top = f]].u;
            }
            for(j = cur[i]; cur[i] != -1;j = cur[i] = E[cur[i]].next)
                if(E[j].c && dep[i] + 1 == dep[E[j].v]) break;
            if(cur[i] != -1) {
                ps[top++] = cur[i];
                i = E[cur[i]].v;
            } else {
                if(0 == top) break;
                dep[i] = -1; i = E[ps[--top]].u;
            }
        }
    }
    return res;
}

void solve() {
	printf("%d\n", m - Dinic(num, source, sink));
}

int main() {
	getMap();
	solve();
	return 0;
}


posted @ 2016-01-15 14:45  lcchuguo  阅读(162)  评论(0编辑  收藏  举报