gulp-px2rem-plugin 插件的一个小bug

  最近在使用这个插件的过程中发现一个bug:

不支持 含有小数的形式。

      查看源码后,修改了下其中的正则,使其支持小数形式(66.66px、.6px )。

       作者的源码最近一次更新都在两年前,所以就简单的记录下       

31行代码处,修改如下
value.replace(/\s+[0]\s+|((\s*)([-.]?)(\d+)([.\d]*?)(px+))/g

 

    插件地址:https://www.npmjs.com/package/gulp-px2rem-plugin

    感谢作者的分享。

 

posted @ 2018-07-30 16:03  雷明nice  阅读(...)  评论(... 编辑 收藏