UVA OJ 10035 - Primary Arithmetic

Primary Arithmetic

Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty.

Input

Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

Output

For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.

Sample Input

123 456
555 555
123 594
0 0

Sample Output

No carry operation.
3 carry operations.
1 carry operation.
#include <cstdio>

using namespace std;
int main()
{
	int n, m;
	while (scanf("%d%d", &n, &m) == 2)
	{
		if (n == 0 && m == 0)
			break;
		int c=0, sum=0;
		while (n != 0 || m != 0)
		{
			c = (n % 10 + m % 10 + c) >= 10 ? 1 : 0;
			sum += c;
			m = m / 10;
			n = n / 10;
		}
		if (sum == 0)
			printf("No carry operation.\n");
		else if (sum==1)
			printf("%d carry operation.\n", sum);
		else
			printf("%d carry operations.\n",sum);
	}
	return 0;
}

  本题陷阱就是当进位为0或1时,operation为单数,忽略了为1是也是单数,所以没有一次AC。

posted on 2014-11-24 20:25  lakeone  阅读(248)  评论(0编辑  收藏  举报

导航