HDU 1312【DFS】

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24708    Accepted Submission(s): 14942


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13

题解:

#include<cstdio>
#include<cstring>
#include<queue>
#include<iostream>
#define INF 99999999
using namespace std;
const int maxn=205;
char s[maxn][maxn];
int vis[maxn][maxn];
int minx=INF;
int n,m;
int dir[4][2]={0,1,-1,0,0,-1,1,0};
int cnt=1;
void dfs(int x,int y){
    for(int i=0;i<4;i++){
        int tx=x+dir[i][0];
        int ty=y+dir[i][1];
        if(tx<0||tx>=m||ty<0||ty>=n)
            continue;
        if(!vis[tx][ty]&&s[tx][ty]!='#'){
            cnt++;
            vis[tx][ty]=1;
            dfs(tx,ty);
        }
    }
}
int main(){
    while(~scanf("%d %d",&n,&m)&&(n+m)){
        memset(vis,0,sizeof vis);
        cnt=1;
        for(int i=0;i<m;i++){
            scanf("%s",s[i]);
        }
        int sx,sy;
        int flag=0;
        for(int i=0;i<m;i++){
            for(int j=0;j<n;j++){
                if(s[i][j]=='@'){
                    sx=i,sy=j;
                    flag=1;
                    break;
                }
            }
            if(flag) break;
        }
        vis[sx][sy]=1;
        dfs(sx,sy);
        printf("%d\n",cnt);
    }
    return 0;
}

posted @ 2018-05-10 23:57  神探小小狄  阅读(147)  评论(0编辑  收藏  举报
【推荐】 程序员网址大全  |  EF CodeFirst  |  百度地图.NET  |  MyNPOI  |  开源  |  我的皮肤  |  ASP.NET MVC4  |  前端提升   |  LINQ   |  WCF   |  EasyUI  | aaronyang 页脚html代码