POJ 1122 FDNY to the Rescue!(最短路)

题目链接

FDNY to the Rescue!

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3405 Accepted: 1063
Description

The Fire Department of New York (FDNY) has always been proud of their response time to fires in New York City, but they want to make their response time even better. To help them with their response time, they want to make sure that the dispatchers know the closest firehouse to any address in the city. You have been hired to write this software and are entrusted with maintaining the proud tradition of FDNY. Conceptually, the software will be given the address of the fire, the locations of the firehouses, street intersections, and the time it takes to cover the distance between each intersection. It will then use this information to calculate how long it takes to reach an address from each firehouse.

Given a specific fire location in the city, the software will calculate the time taken from all the fire stations located in the city to reach the fire location. The list of fire stations will be sorted from shortest time to longest time. The dispatcher can then pick the closest firestation with available firefighters and equipment to dispatch to the fire.
Input

Line 1:

of intersections in the city, a single integer (henceforth referred to as N) N<20

Lines 2 to N+1:
A table (square matrix of integer values separated by one or more spaces) representing the time taken in minutes between every pair of intersections in the city. In the sample input shown below the value "3" on the 1st row and the 2nd column represents the time taken from intersection #1 to reach intersection #2.

Similarly the value "9" on the 4th row and the 2nd column represents the time taken from intersection #4 to reach intersection #2.

A value of -1 for time means that it is not possible to go directly from the origin intersection (row #) to the destination intersection (column #). All other values in the table are non-negative.

Line N+2:
An integer value n (<= N) indicating the intersection closest to the fire location followed by one or more integer values for the intersections closest to the fire stations (all on one line, separated by one or more spaces) will follow the input matrix.

Notes on input format:

  1. The rows and columns are numbered from 1 to N.
  2. All input values are integers
  3. All fire locations are guaranteed reachable from all firehouses.
  4. All distance calculations are made from the intersection closest to each firehouse to the intersection closest to the fire.
    Output

Line 1:
A label line with the headings for each column, exactly as shown in the example.

Line 2 onwards (one line for each fire station):
A sorted list (based on time) showing the fire station (origin), the destination site, time taken and a complete shortest path of nodes from the originating fire station to the fire location.

Notes on output format:

  1. Columns are tab separated.
  2. If two or more firehouses are tied in time they can be printed in any order.
  3. If more than one path exists that has the same minimal time for a given location & firehouse, either one can be printed on the output.
  4. If the fire location and the fire station locations happen to be the same intersection, the output will indicate that the origin and destination have the same intersection number, the time will be "0" and the nodes in the shortest path will show just one number, the fire location.
    Next is the picture for the sample input data.

Sample Input

6 
0  3  4 -1 -1 -1 
-1 0  4  5 -1 -1 
2  3  0 -1 -1  2 
8  9  5  0  1 -1 
7  2  1 -1  0 -1 
5 -1  4  5  4  0 
2  4  5  6 

In the above input the last line indicates that "2" is the location of the fire and "4", "5" and "6" are the intersections where fire stations are located.

Sample Output

Org	Dest	Time	Path
5	2	2	5	2
4	2	3	4	5	2
6	2	6	6	5	2

题意:给一个无向图,1个终点,若干起点,让你求若干起点到终点的最短路和最短路径。

PS:注意ZOJ 1053的输出格式

AC代码


#include<cstring>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<stack>
using namespace std;
const int N = 30;
const int inf = 0x3f3f3f3f;
struct node{
    int u, v, w;
    int path[N];
}q[N*N];
int n, ed, cnt;
int e[N][N], dis[N], P[N];
bool vis[N];
char s[1000];
void Dij(int st){
    memset(vis, false, sizeof(vis));
    vis[st] = true;
    for(int i = 1; i<= n; i++){
        dis[i] = e[st][i];
        q[cnt].path[i] = st;
    }
    q[cnt].path[st] = 0;
    for(int  i = 1; i < n; i++){
        int minn = inf, u;
        for(int j = 1; j <= n; j++){
            if(dis[j] < minn && !vis[j]){
                minn = dis[j];
                u = j;
            }
        }
        if(minn == inf) break;
        vis[u] = true;
        for(int j = 1; j <= n; j++){
            if(dis[j] > dis[u] + e[u][j] && !vis[j]){
                dis[j] = dis[u] + e[u][j];
                q[cnt].path[j] = u;
            }
        }
    }
}
bool cmp(node a, node b){
    return a.w < b.w;
}
int main(){
    #ifdef ONLINE_JUDGE
    #else
        freopen("in.txt", "r", stdin);
    #endif // ONLINE_JUDGE
    int t;
    while(~scanf("%d", &n)){

        cnt = 0;
        for(int i = 1; i <= n; i++){
            for(int  j = 1; j <= n; j++){
                scanf("%d", &e[i][j]);
                if(e[i][j] == -1) e[i][j] = inf;
            }
        }
        scanf("%d", &ed);
        gets(s);
        int i = 0;

        int len = strlen(s);
        while(i < len){
            int st = 0;
            while(s[i] < '0' || s[i] > '9'){
                i++;
            }
            while(s[i] >= '0' && s[i]<='9'){
                st = st * 10 + s[i] - '0';
                i++;
            }
            Dij(st);
            q[cnt].u = st;q[cnt].v = ed;q[cnt++].w = dis[ed];
            i++;
        }
        sort(q, q + cnt, cmp);
        printf("Org\tDest\tTime\tPath\n");
        for(int i = 0; i < cnt; i++){
            printf("%d\t%d\t%d\t", q[i].u, q[i].v, q[i].w);
            stack<int> S;
            int ss = q[i].v;
            while(ss){
                S.push(ss);
                ss = q[i].path[ss];
            }
            bool flag = false;
            while(!S.empty()){
                if(!flag) flag = true;
                else printf("\t");
                printf("%d", S.top());S.pop();
            }
            printf("\n");
        }
        if(t != 0) printf("\n");
    }
    return 0;
}

posted on 2018-10-24 17:39  坤sir  阅读(150)  评论(0编辑  收藏  举报

导航