Poj 1679 The Unique MST

The Unique MST
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 36725   Accepted: 13381

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

思路:判断最小生成树唯一,也可以用次小生成树做,求出最小生成树,标记已使用过的边,加入一条新的边,去掉最小生成树中的最大边,就是次小生成树的值,如果次小生成树跟最小生成树的值相同,那么最小生成树不唯一,否则唯一。

(1)对图中每一条边扫描,判断有没有权值相同的边

(2)有相同边:标记他们,用Kruskal或Prim求一次MST。把标记的边且已使用的边去掉,再求一次MST,如果两次求得值相同,则MST不唯一,否则唯一。

(3)没有相同边:MST唯一。

AC代码:

#include <algorithm>
#include <iostream>
using namespace std;
const int N=101000;
struct node{
    int u,v,d,div;
}q[N];
int n,m,cnt;
int pre[N];
void init(){
    for(int i=1;i<=n;i++){
        pre[i]=i;
    }
}
int Find(int x){
    if(x!=pre[x]) pre[x]=Find(pre[x]);
    return pre[x];
}
void join(int x,int y){
    int tx=Find(x);
    int ty=Find(y);
    if(tx!=ty) pre[ty]=tx;
}
bool cmp(node a,node b){
    return a.d<b.d;
}
int Kru(){
    int ans=0;
    for(int i=1;i<=m;i++){
        if(Find(q[i].u)!=Find(q[i].v)&&q[i].div!=2){
            join(q[i].u,q[i].v);
            ans+=q[i].d;
            if(q[i].div==1) q[i].div=2;
            cnt++;
        }
    }
    return ans;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        init();
        for(int i=1;i<=m;i++){
            scanf("%d%d%d",&q[i].u,&q[i].v,&q[i].d);
            q[i].div=0;
        }
        sort(q+1,q+1+m,cmp);
        bool flag=false;
        for(int i=1;i<m;i++){
            if(q[i].d==q[i+1].d){
                flag=true;
                q[i].div=q[i+1].div=1;
            }
        }
        cnt=0;
        int ans1=Kru();
        init();
        int ans2=Kru();
        if(!flag){
            printf("%d\n",ans1);
        }
        else{
            if(ans1==ans2||cnt<2*n-2) printf("Not Unique!\n");
            else printf("%d\n",ans1);
        }
    }
    return 0;
}
View Code

 

posted on 2018-09-29 11:11  坤sir  阅读(117)  评论(0编辑  收藏  举报

导航