POJ 1258 Agri-Net

题目链接

Agri-Net

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 69042 Accepted: 28617
Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

思路:最小生成树

AC代码
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int N=110;
const int inf=0x3f3f3f3f;
int e[N][N],dis[N],Next[N];
int n;
void init(){
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            if(i==j) e[i][j]=0;
            else e[i][j]=inf;
        }
    }
}
int Prim(int st){
    int ans=0;
    for(int i=1;i<=n;i++){
        dis[i]=e[st][i];
        Next[i]=st;
    }
    Next[st]=-1;
    int minn,u;
    for(int i=1;i<n;i++){
        minn=inf,u=-1;
        for(int j=1;j<=n;j++){
            if(dis[j]<minn&&Next[j]!=-1){
                minn=dis[j];
                u=j;
            }
        }
        if(u==-1 )break;
        ans+=minn;
        Next[u]=-1;
        for(int j=1;j<=n;j++){
            if(dis[j]>e[u][j]&&Next[j]!=-1){
                dis[j]=e[u][j];
                Next[j]=u;
            }
        }
    }
    return ans;
}
int main(){
    while(~scanf("%d",&n)){
        init();
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&e[i][j]);
            }
        }
        int ans=Prim(1);
        printf("%d\n",ans);
    }
    return 0;
}

posted on 2018-09-27 17:41  坤sir  阅读(85)  评论(0编辑  收藏  举报

导航