ZOJ 1586 QS Network

题目链接

QS Network

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:

 


A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

 


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370

 

题意:QS之间通过网络进行通讯,如果两个QS需要通讯,他们需要买两个网络适配器,每个QS一个,以及一段网线,每个是适配器只用于单一通信中,也就是说如果一个QS想建立4个通信,那么需要买4个适配器。在通信中,一个QS向所有和他连接的QS发送消息,接收到消息的QS又向它连接着的QS发送,直到所有QS都接到消息

分析:最小生成树

AC代码:

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;
const int N=1010;
const int inf=0x3f3f3f3f3f;
int n;
int s[N],dis[N],e[N][N];
bool vis[N];
int Prim(int st){
    int ans=0;
    memset(vis,false, sizeof((vis)));
    vis[st]=true;
    for(int i=1;i<=n;i++){
        dis[i]=e[st][i];
    }
    int minn,u;
    for(int i=1;i<n;i++){
        minn=inf;
        for(int j=1;j<=n;j++){
            if(minn>dis[j]&&!vis[j]){
                minn=dis[j];
                u=j;
            }
        }
        if(minn==inf) break;
        vis[u]=true;
        ans+=minn;
        for(int j=1;j<=n;j++){
            if(dis[j]>e[u][j]&&!vis[j]) dis[j]=e[u][j];
        }
    }
    return ans;
}
void init(){
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            if(i==j) e[i][j]=0;
            else e[i][j]=inf;
        }
    }
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        init();
        for(int i=1;i<=n;i++){
            scanf("%d",&s[i]);
        }
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&e[i][j]);
                if(i==j) e[i][j]=0;
                else e[i][j]+=s[i]+s[j];
            }
        }
        int ans=Prim(1);
        printf("%d\n",ans);
    }
    return 0;
}
View Code

 

posted on 2018-09-26 17:24  坤sir  阅读(139)  评论(0编辑  收藏  举报

导航